Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Removed Jeweler for gem creation and used bundler instead

  • Loading branch information...
commit ad250bcdaad9a77f9c6b3d52a67e9bae79dec3ee 1 parent 15c48a3
Damien White authored
6 .gitignore
View
@@ -7,4 +7,8 @@ tmp/*
test/SampleService/App_Data/TestDB.mdf
test/SampleService/App_Data/TestDB_Log.ldf
pkg/*
-doc/*
+doc/*
+*.gem
+.bundle
+Gemfile.lock
+pkg/*
13 Gemfile
View
@@ -1,13 +1,4 @@
source "http://rubygems.org"
-gem "activesupport", ">= 2.3.5"
-gem "rest-client", ">= 1.5.1"
-gem "nokogiri", ">= 1.4.2"
-
-group :test do
- gem "cucumber"
- gem "sham"
- gem "faker"
- gem "machinist"
- gem "rspec"
-end
+# Specify your gem's dependencies in ruby_odata.gemspec
+gemspec
46 Gemfile.lock
View
@@ -1,46 +0,0 @@
-GEM
- remote: http://rubygems.org/
- specs:
- activesupport (3.0.5)
- builder (3.0.0)
- cucumber (0.10.0)
- builder (>= 2.1.2)
- diff-lcs (~> 1.1.2)
- gherkin (~> 2.3.2)
- json (~> 1.4.6)
- term-ansicolor (~> 1.0.5)
- diff-lcs (1.1.2)
- faker (0.9.5)
- i18n (~> 0.4)
- gherkin (2.3.4-x86-mingw32)
- json (~> 1.4.6)
- i18n (0.5.0)
- json (1.4.6-x86-mingw32)
- machinist (1.0.6)
- mime-types (1.16)
- nokogiri (1.4.4.1-x86-mingw32)
- rest-client (1.6.1)
- mime-types (>= 1.16)
- rspec (2.5.0)
- rspec-core (~> 2.5.0)
- rspec-expectations (~> 2.5.0)
- rspec-mocks (~> 2.5.0)
- rspec-core (2.5.1)
- rspec-expectations (2.5.0)
- diff-lcs (~> 1.1.2)
- rspec-mocks (2.5.0)
- sham (0.4.0)
- term-ansicolor (1.0.5)
-
-PLATFORMS
- x86-mingw32
-
-DEPENDENCIES
- activesupport (>= 2.3.5)
- cucumber
- faker
- machinist
- nokogiri (>= 1.4.2)
- rest-client (>= 1.5.1)
- rspec
- sham
20 Rakefile
View
@@ -1,24 +1,10 @@
require 'rake/rdoctask'
+require 'bundler'
+
Rake::RDocTask.new do |rd|
rd.main = "README.rdoc"
rd.rdoc_files.include("README.rdoc", "CHANGELOG.rdoc", "lib/**/*.rb")
rd.rdoc_dir = 'doc'
end
-begin
- require 'jeweler'
- Jeweler::Tasks.new do |gemspec|
- gemspec.name = "ruby_odata"
- gemspec.summary = "Ruby consumer of OData services."
- gemspec.description = "An OData Client Library for Ruby. Use this to interact with OData services"
- gemspec.email = "damien.white@visoftinc.com"
- gemspec.homepage = "http://github.com/visoft/ruby_odata"
- gemspec.authors = ["Damien White"]
- gemspec.add_dependency('activesupport', '>= 2.3.5')
- gemspec.add_dependency('rest-client', '>= 1.5.1')
- gemspec.add_dependency('nokogiri', '>= 1.4.2')
- gemspec.rubyforge_project = 'ruby-odata'
- end
-rescue LoadError
- puts "Jeweler not available. Install it with: gem install jeweler"
-end
+Bundler::GemHelper.install_tasks
1  VERSION
View
@@ -1 +0,0 @@
-0.0.8
3  lib/ruby_odata/version.rb
View
@@ -0,0 +1,3 @@
+module OData
+ VERSION = "0.0.8"
+end
102 ruby_odata.gemspec
View
@@ -1,85 +1,31 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in rakefile, and run the gemspec command
# -*- encoding: utf-8 -*-
+$:.push File.expand_path("../lib", __FILE__)
+require "ruby_odata/version"
Gem::Specification.new do |s|
- s.name = %q{ruby_odata}
- s.version = "0.0.7"
-
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Damien White"]
- s.date = %q{2010-07-04}
+ s.name = "ruby_odata"
+ s.version = OData::VERSION
+ s.platform = Gem::Platform::RUBY
+ s.authors = ["Damien White"]
+ s.email = ["damien.white@visoftinc.com"]
+ s.homepage = %q{http://github.com/visoft/ruby_odata}
+ s.summary = %q{Ruby consumer of OData services.}
s.description = %q{An OData Client Library for Ruby. Use this to interact with OData services}
- s.email = %q{damien.white@visoftinc.com}
- s.extra_rdoc_files = [
- "CHANGELOG.rdoc",
- "LICENSE",
- "README.rdoc"
- ]
- s.files = [
- ".gitignore",
- "CHANGELOG.rdoc",
- "LICENSE",
- "README.rdoc",
- "Rakefile",
- "VERSION",
- "config/cucumber.yml",
- "features/batch_request.feature",
- "features/complex_types.feature",
- "features/query_builder.feature",
- "features/service.feature",
- "features/service_manage.feature",
- "features/step_definitions/service_steps.rb",
- "features/support/env.rb",
- "features/support/hooks.rb",
- "features/type_conversion.feature",
- "lib/ruby_odata.rb",
- "lib/ruby_odata/class_builder.rb",
- "lib/ruby_odata/operation.rb",
- "lib/ruby_odata/query_builder.rb",
- "lib/ruby_odata/service.rb",
- "ruby_odata.gemspec",
- "test/Cassini x64.bat",
- "test/Cassini x86.bat",
- "test/SampleService/App_Code/AuditFields.cs",
- "test/SampleService/App_Code/Entities.cs",
- "test/SampleService/App_Code/Model.Designer.cs",
- "test/SampleService/App_Code/Model.edmx",
- "test/SampleService/App_Code/ModelContainerExtended.cs",
- "test/SampleService/App_Data/_TestDB.mdf",
- "test/SampleService/App_Data/_TestDB_Log.ldf",
- "test/SampleService/Entities.svc",
- "test/SampleService/web.config",
- "test/blueprints.rb"
- ]
- s.homepage = %q{http://github.com/visoft/ruby_odata}
- s.rdoc_options = ["--charset=UTF-8"]
- s.require_paths = ["lib"]
- s.rubyforge_project = %q{ruby-odata}
- s.rubygems_version = %q{1.3.7}
- s.summary = %q{Ruby consumer of OData services.}
- s.test_files = [
- "test/blueprints.rb"
- ]
- if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
- s.specification_version = 3
+ s.rubyforge_project = "ruby-odata"
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<activesupport>, [">= 2.3.5"])
- s.add_runtime_dependency(%q<rest-client>, [">= 1.5.1"])
- s.add_runtime_dependency(%q<nokogiri>, [">= 1.4.2"])
- else
- s.add_dependency(%q<activesupport>, [">= 2.3.5"])
- s.add_dependency(%q<rest-client>, [">= 1.5.1"])
- s.add_dependency(%q<nokogiri>, [">= 1.4.2"])
- end
- else
- s.add_dependency(%q<activesupport>, [">= 2.3.5"])
- s.add_dependency(%q<rest-client>, [">= 1.5.1"])
- s.add_dependency(%q<nokogiri>, [">= 1.4.2"])
- end
-end
+ s.add_dependency('activesupport', '>= 2.3.5')
+ s.add_dependency('rest-client', '>= 1.5.1')
+ s.add_dependency('nokogiri', '>= 1.4.2')
+
+ s.add_development_dependency('rspec')
+ s.add_development_dependency('cucumber')
+ s.add_development_dependency('sham')
+ s.add_development_dependency('faker')
+ s.add_development_dependency('machinist')
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
+ s.require_paths = ["lib"]
+end
Please sign in to comment.
Something went wrong with that request. Please try again.