Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We鈥檒l occasionally send you account related emails.

Already on GitHub? Sign in to your account

feat!: bump minimum node version to 14.18.0 #8662

Merged
merged 1 commit into from Jun 19, 2022

Conversation

bluwy
Copy link
Member

@bluwy bluwy commented Jun 19, 2022

Description

Bump Vite to node >=14.18.0

Additional context

Mostly find + replace. Hopefully I didn't miss anything 馃槵

Ref #8309 (comment), that fs.rmSync requires node 14.14. node: protocols with require() requires `node 14.18.

Ref https://twitter.com/bluwyoo/status/1538224383507845120, a poll is made about whether users are mindful of the version change. And a majority leans on "any version works", followed by 14.18 being fine for them.

Thought I'd separate this change from #8309 so it's easier to review.


What is the purpose of this pull request?

  • Bug fix
  • New Feature
  • Documentation update
  • Other

Before submitting the PR, please make sure you do the following

  • Read the Contributing Guidelines.
  • Read the Pull Request Guidelines and follow the Commit Convention.
  • Check that there isn't already a PR that solves the problem the same way to avoid creating a duplicate.
  • Provide a description in this PR that addresses what the PR is solving, or reference the issue that it solves (e.g. fixes #123).
  • Ideally, include relevant tests that fail without this PR but pass with it.

@bluwy bluwy mentioned this pull request Jun 19, 2022
9 tasks
@patak-dev patak-dev merged commit 8a05432 into vitejs:main Jun 19, 2022
13 checks passed
@bluwy bluwy deleted the bump-node-version branch June 19, 2022 17:53
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

2 participants