Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

101_initial_cluster not compatible Kubernetes 1.16 #5411

Open
liys87x opened this issue Nov 6, 2019 · 3 comments
Open

101_initial_cluster not compatible Kubernetes 1.16 #5411

liys87x opened this issue Nov 6, 2019 · 3 comments
Assignees
Labels
Milestone

Comments

@liys87x
Copy link

@liys87x liys87x commented Nov 6, 2019

helm install ../../helm/vitess -f 101_initial_cluster.yaml

Error: validation failed: [unable to recognize "": no matches for kind "Deployment" in version "apps/v1beta1", unable to recognize "": no matches for kind "StatefulSet" in version "apps/v1beta1", unable to recognize "": no matches for kind "EtcdCluster" in version "etcd.database.coreos.com/v1beta2"]

@liys87x

This comment has been minimized.

Copy link
Author

@liys87x liys87x commented Nov 6, 2019

Continued deprecation of extensions/v1beta1, apps/v1beta1, and apps/v1beta2 APIs; these extensions will be retired in 1.16!

All resources under apps/v1beta1 and apps/v1beta2 - use apps/v1 instead

@morgo morgo added the Type: Bug label Nov 7, 2019
@parthibd

This comment has been minimized.

Copy link

@parthibd parthibd commented Nov 11, 2019

Faced the same bug today while trying out the examples.

@morgo morgo self-assigned this Nov 28, 2019
@morgo

This comment has been minimized.

Copy link
Collaborator

@morgo morgo commented Nov 28, 2019

I took a look at this today. There will be a bit of work to do, because the etcd-operator we suggest using also uses the deprecated APIs. It looks like they have a pull request waiting to merge, which worked for me: coreos/etcd-operator#2127

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.