Skip to content
master
Switch branches/tags
Code

Latest commit

 

Git stats

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
 
 
src
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The transcriber

Open source transcribing tool. Respects the privacy of your data, can be plugged to many external tools.

Requirements

Because I'm testing WebComponents with this project, you will have to use an up to date Chrome/Chromium version. Unfortunately Firefox support for WebComponents is pretty poor at the moment.

Installation

Javascript

AHAH, you thought you wouldn't need any javascript stuff. You're screwed.

npm install
bower install

Hack to use the unpublished Dom.Size module

Install dependencies by running elm make src/elm/Main.elm. It should start downloading dependencies and then complain about Dom.Size module.

I cannot find module 'Dom.Size'.

Module 'Main' is trying to import it.

Open the elm-stuff/packages/elm-lang/dom/1.1.1/elm-package.json file and change

    "exposed-modules": [
        "Dom",
        "Dom.Scroll",
        "Dom.LowLevel"
    ],

to

    "exposed-modules": [
        "Dom",
        "Dom.Scroll",
        "Dom.LowLevel",
        "Dom.Size"
    ],

Then open elm-stuff/packages/elm-lang/dom/1.1.0/src/Dom/Size.elm and change the first line from :

module Dom.Size exposing (height, width, Boundary)

to

module Dom.Size exposing (height, width, Boundary(..))

Then, the code should compile just fine.

Compile and run

npm start

Open http://localhost:8080/ in your browser and enjoy.

Links

About

Open source transcribing tool written in Elm. Respects the privacy of your data, can be plugged to many external tools.

Resources

License

Releases

No releases published

Packages

No packages published