Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Can't Get Gem Working #206

Closed
djiang opened this Issue · 5 comments

4 participants

@djiang

I'm trying to use the gem in my application and wanted to test it out in the console first.

I'm using Rails 3.2.12 along with Ruby 1.9.3p194

  • I added gem 'redcarpet' to my Gemfile
  • ran bundle install
  • started my console with bundle exec rails c (also tried without bundle exec)
  • Tried running the following commands and got the following outputs:
Loading development environment (Rails 3.2.12)
1.9.3p194 :001 > markdown = Redcarpet::Markdown.new(Redcarpet::Render::HTML)
 => #<Redcarpet::Markdown:0x007fe3ca8aba78> 
1.9.3p194 :002 > markdown.render("This is *bongos*, indeed.")
 => "" 
1.9.3p194 :003 > markdown.render("# Hello World")
 => "<h1></h1>\n" 

Any ideas as to what's going on? Do I need to compile anything when using the Gem version?

Thanks in advance!

@hron84

Can you share your Gemfile with us? Your example is working for me...

Also please try delete Gemfile.lock and re-run bundle install

@mekf

I think redcarpet does not work with rails 3.2.12. I updated my Gemfile to 3.2.12 and redcarpet stop working. Downgrading back to 3.2.11 and everything works again

@hron84

I using RedCarpet and Rails 3,2,12 without any problem.

@mekf

FYI: I think I got a gems conflict and/or bad gem installation. Emptied the gemset to start from scratch and everything is working again. Removed the Gemfile.lock didn't help btw

@mattr-
Collaborator

:metal: Glad you got it working!

@mattr- mattr- closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.