RuntimeError: unknown VMODL type AnyType #91

Open
richardmoe opened this Issue Jan 22, 2014 · 8 comments

Comments

Projects
None yet
7 participants

I have a vSphere 5.5 cluster which I am connecting to. Installed rvc in Ubuntu 13.10 as a gem and patched it to support Windows Domain logins. I am able to login and run 'ls' on / (root), but when I 'cd 1' and try to run ls in the 'subdir' i just get an error message: RuntimeError: unknown VMODL type AnyType.
Tried to downgrade rbvmomi to 1.6.0, but no luck. Any ideas?

I'm noticing the same issue with a vSphere 5.5 cluster on Ubuntu 12.04.4 LTS. The issue did not begin until I update the rvc gem to rvc-1.8.0. (I'm not sure of the previous version).

The first issue that I got was this:

/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- rbvmomi/pbm (LoadError)

Then after upgrading rbvmomi to rbvmomi-1.8.1 I started getting this:

RuntimeError: unknown VMODL type AnyType

iiro commented Apr 18, 2014

Hi,
have you guys found a sensible way to fix this...? Some have downgraded the rbvmomi back to 1.6.0 I suppose...

spkane commented Apr 23, 2014

I could only get this working by downgrading nokogiri to 1.5.5

rbwsam commented Jun 22, 2014

@spkane's solution of downgrading to nokogiri 1.5.5 worked for me: ruby 2.1.2p95, rvc (1.8.0)

spkane commented Jun 22, 2014

@rbwsam Yes, that works, but I really wish they'd just release the fix for this. Since lots of projects use nokogiri and being tied to an old version is not ideal or even possible in some cases.

@spkane Downgrading worked for me as well. Thanks!

GeorgFoc commented Nov 6, 2014

I also have this Problem. The Downgrading of nokogiri works well, but I have to use nokogiri >= 1.5.11 for puppet beaker.
Would rvc becomes an upgrade to support nokogiri > 1.5.10?

This was the working Workaround. THX @ALL
dekz/rbvmomi@571433c

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment