Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

sk8 deployment to vSphere env fails with multiple datacenters #7

Open
lamw opened this Issue Jan 31, 2019 · 1 comment

Comments

Projects
None yet
1 participant
@lamw
Copy link

lamw commented Jan 31, 2019

After powering on sk8, I found that there were no Controller/Worker nodes deployment. I logged into the c01 and looking at /var/log/sk8/vsphere.log, it looks like the code assumes there's only a single vSphere datacenter

govc: default datacenter resolves to multiple instances, please specify
FATAL [1548905820] failed to get VM's info

Wondering if a quick solution would be to simply look up the currently deployed VM and then walk back up to the parent Datacenter and use that as inventory path?

Here's what my vSphere Inventory looks like in case that helps:
screen shot 2019-01-30 at 10 26 32 pm

@lamw

This comment has been minimized.

Copy link
Author

lamw commented Feb 14, 2019

I did some more digging and it looks like govc vm.info doesn't work if you have more than one Datacenter, which is why I ran into the issue. You need to set the scope by specifying GOVC_DATACENTER property

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.