Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

_repose is missing #17

Closed
holomorph opened this Issue · 2 comments

2 participants

@holomorph

I tried adapting the old zsh completions to the new repose

#compdef repose

_arguments -s \
  {-h,--help}'[display this help and exit]' \
  {-v,--version}'[display version]' \
  {-f,--files}'[generate complementing files database]' \
  {-d,--drop}'[drop package from database]' \
  {-r,--root=-}'[repository root directory]' \
  {-p,--pool=-}'[set the pool to find packages in it]:pool:_directories' \
  {-a,--arch=-}'[the primary architecture of the database]:arch:(i686 x86_64)$
  {-j,--bzip2}'[compress the database with bzip2]' \
  {-J,--xz}'[compress the database with xz]' \
  {-z,--gzip}'[compress the database with gzip]' \
  {-Z,--compress}'[compress the database with LZ]' \
  '--rebuild[force rebuild the repo]' \
  '1:database:_files -g "*.db*~(.,@)"' \
  '*::package files:_files -g "*.pkg.tar*~(.,@)"'
@vodik vodik closed this issue from a commit
@holomorph holomorph adapted the old zsh completions to the new repose
Closes #17

Signed-off-by: Simon Gomizelj <simongmzlj@gmail.com>
7b42fcf
@vodik vodik closed this in 7b42fcf
@vodik
Owner

Needs some work, but thanks. Did it this way to give you credit.

@holomorph

thanks, yeah I realize now it's kind of wrong :(

@vodik vodik referenced this issue from a commit
@vodik Fixed up site-function.
See #15 and #17
f9958fc
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.