Skip to content
Permalink
Browse files

puppet: Fix runtime

Added new dependencies that fixes runtime
Closes #17162

Signed-off-by: Nathan Owens <ndowens04@gmail.com>
  • Loading branch information
ndowens authored and xtraeme committed Dec 7, 2019
1 parent b5cafe0 commit c26e0dad414423ee3cc5d8bebe5088c4fe7561d8
Showing with 28 additions and 2 deletions.
  1. +25 −0 srcpkgs/puppet/patches/0001-maint-Add-missing-require-singleton.patch
  2. +3 −2 srcpkgs/puppet/template
@@ -0,0 +1,25 @@
From 6ce9bee9e23010893952a5b2f6e8fbeb6c4b3628 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Romain=20Tarti=C3=A8re?= <romain@blogreen.org>
Date: Mon, 25 Nov 2019 15:11:45 -1000
Subject: [PATCH] (maint) Add missing require: singleton

This file use the Singleton pattern implemented by Ruby's Singleton
class in the singleton module. Require the singleton module before
using the Singleton class.
---
lib/puppet/runtime.rb | 1 +
1 file changed, 1 insertion(+)

diff --git lib/puppet/runtime.rb lib/puppet/runtime.rb
index 1d52cec59b..73bd9eb07f 100644
--- lib/puppet/runtime.rb
+++ lib/puppet/runtime.rb
@@ -1,4 +1,5 @@
require 'puppet/http'
+require 'singleton'

class Puppet::Runtime
include Singleton
--
2.24.0

@@ -1,12 +1,13 @@
# Template file for 'puppet'
pkgname=puppet
version=6.11.1
revision=1
revision=2
archs=noarch
build_style=ruby-module
hostmakedepends="ruby facter-devel hiera"
makedepends="facter-devel"
depends="ruby facter hiera ruby-semantic_puppet"
depends="ruby facter-devel hiera ruby-semantic_puppet
ruby-concurrent-ruby ruby-rubysl-singleton ruby-deep_merge"
short_desc="Server automation framework and application"
maintainer="Orphaned <orphan@voidlinux.org>"
license="Apache-2.0"

0 comments on commit c26e0da

Please sign in to comment.
You can’t perform that action at this time.