Skip to content
Permalink
Browse files

🏗Build: Use docker images from docker hub [Travis-CI]

- github docker repository doesn't support the multi-architecture images, thus docker hub shall be used
  • Loading branch information
vookimedlo committed Dec 7, 2019
1 parent dde4008 commit 2bfe724c30db78edce105386aaf6fe2cc47c025e
Showing with 2 additions and 3 deletions.
  1. +2 −3 .travis.yml
@@ -44,9 +44,8 @@ matrix:
env: QT=latestDistroOfficial RELEASE=stable DISTRO=fedora DEB=no

install:
- '[ "$TRAVIS_OS_NAME" != linux ] || docker login docker.pkg.github.com --username vookimedlo --password "$packages_read_token"'
- '[ "$TRAVIS_OS_NAME" != linux ] || docker pull docker.pkg.github.com/vookimedlo/docker-images/"$DISTRO"-qt:"$QT"_"$CC"_"$RELEASE"'
- '[ "$TRAVIS_OS_NAME" != linux ] || docker run -d --name linux_docker --rm -ti docker.pkg.github.com/vookimedlo/docker-images/"$DISTRO"-qt:"$QT"_"$CC"_"$RELEASE" bash'
- '[ "$TRAVIS_OS_NAME" != linux ] || docker pull vookimedlo/"$DISTRO"-qt:"$QT"_"$CC"_"$RELEASE"'
- '[ "$TRAVIS_OS_NAME" != linux ] || docker run -d --name linux_docker --rm -ti vookimedlo/"$DISTRO"-qt:"$QT"_"$CC"_"$RELEASE" bash'
- '[ "$TRAVIS_OS_NAME" != linux ] || ([ "$DISTRO" != ubuntu ] && [ "$DISTRO" != debian ]) || docker exec linux_docker apt-get update -qq'
- '[ "$TRAVIS_OS_NAME" != linux ] || ([ "$DISTRO" != ubuntu ] && [ "$DISTRO" != debian ]) || docker exec linux_docker apt-get -y install libraw-dev'
- '[ "$TRAVIS_OS_NAME" != linux ] || [ "$DISTRO" != fedora ] || docker exec linux_docker yum -y install LibRaw LibRaw-devel'

0 comments on commit 2bfe724

Please sign in to comment.
You can’t perform that action at this time.