Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Error: Cannot find module 'eyes' #239

Closed
webngt opened this Issue · 2 comments

3 participants

@webngt

Just installed vows in OS X 10.8.2 as specified at http://vowsjs.org/#installing. Then I tried to run vows CLI according to the reference http://vowsjs.org/#reference. Not surprisingly it did not work since vows executable was not on PATH environment variable. After I added vows installation bin directory to PATH with

export PATH=$PATH:$HOME/.npm/vows/0.6.4/package/bin 

I got the following exception when running vows.

$ vows 

module.js:340
    throw err;
          ^
Error: Cannot find module 'eyes'
    at Function.Module._resolveFilename (module.js:338:15)
    at Function.Module._load (module.js:280:25)
    at Module.require (module.js:362:17)
    at require (module.js:378:17)
    at Object.<anonymous> (/Users/aleks/.npm/vows/0.6.4/package/bin/vows:23:15)
    at Module._compile (module.js:449:26)
    at Object.Module._extensions..js (module.js:467:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.runMain (module.js:492:10)

I'm not sure that this is a bug and perhaps I've missed something during installation so I'd appreciate any good advise on the subject.

@mmalecki

Try npm install vows -g. I'll update the website later. Leaving it open for now.

@webngt

npm install vows -g helps. Thank you!

@indexzero indexzero closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.