New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Changes from Validate_ to datatypes is not backward compatible with Puppet 3.8.7 #1053

Open
mbelscher opened this Issue Mar 24, 2017 · 3 comments

Comments

Projects
None yet
4 participants
@mbelscher

Affected Puppet, Ruby, OS and module versions/distributions

  • Puppet:3.8.7
  • Ruby:
  • Distribution:
  • Module version: Master

How to reproduce (e.g Puppet code you use)

What are you seeing

Error: Syntax error at 'Boolean'; expected ')' at /etc/puppet/modules/nginx/manifests/init.pp:31 on node ip-172-31-29-227.ec2.internal
Error: Syntax error at 'Boolean'; expected ')' at /etc/puppet/modules/nginx/manifests/init.pp:31 on node ip-172-31-29-227.ec2.internal

What behaviour did you expect instead

Output log

puppet parser validate /etc/puppet/modules/nginx/manifests/init.pp
Error: Could not parse for environment production: Syntax error at 'Boolean'; expected ')' at /etc/puppet/modules/nginx/manifests/init.pp:31

Any additional information you'd like to impart

README.md indicates that this module is compatible with a minimum version of 3.8.7 or later but
metadata.json has been updated to 4.6.1 to 5.0.0

@alexjfisher

This comment has been minimized.

Show comment
Hide comment
@alexjfisher

alexjfisher Mar 25, 2017

Member

@mbelscher Puppet 3 support has recently been dropped. Release 0.6.0 is the last version to support it. The next release will be 1.0.0 and require puppet 4.6 or later. Thanks for pointing out that our README needed updating too.

In general, if they haven't already, all voxpupuli modules will be dropping puppet 3 support soon. Puppet 3 has been officially EOL since the beginning of the year. If you find you need help upgrading to Puppet 4, there are always plenty of people willing to help on the #voxpupuli IRC channel.

Member

alexjfisher commented Mar 25, 2017

@mbelscher Puppet 3 support has recently been dropped. Release 0.6.0 is the last version to support it. The next release will be 1.0.0 and require puppet 4.6 or later. Thanks for pointing out that our README needed updating too.

In general, if they haven't already, all voxpupuli modules will be dropping puppet 3 support soon. Puppet 3 has been officially EOL since the beginning of the year. If you find you need help upgrading to Puppet 4, there are always plenty of people willing to help on the #voxpupuli IRC channel.

@igalic

This comment has been minimized.

Show comment
Hide comment
@igalic

igalic Mar 28, 2017

Member

@alexjfisher unfortunately, from what i gather, that release is broken

Member

igalic commented Mar 28, 2017

@alexjfisher unfortunately, from what i gather, that release is broken

@oranenj

This comment has been minimized.

Show comment
Hide comment
@oranenj

oranenj Apr 6, 2017

Contributor

@igalic in which way is it broken? Big issues can be fixed in the puppet3 branch.

Contributor

oranenj commented Apr 6, 2017

@igalic in which way is it broken? Big issues can be fixed in the puppet3 branch.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment