Browse files

Fix puppet-lint alignment and default case.

  • Loading branch information...
1 parent c0f9e95 commit 4b75cc31b10611714399a0687d554cf35364f420 @nanliu nanliu committed Apr 30, 2012
Showing with 6 additions and 2 deletions.
  1. +5 −1 manifests/init.pp
  2. +1 −1 tests/npm.pp
View
6 manifests/init.pp
@@ -34,6 +34,10 @@
before => Package['nodejs'],
}
}
+
+ default: {
+ fail("Class nodejs does not support $::operatingsystem")
+ }
}
package { 'nodejs':
@@ -46,7 +50,7 @@
# npm installation is a hack since there's no packages:
exec { 'install_npm':
- command => 'curl http://npmjs.org/install.sh | sed "s/<\/dev\/tty//g" > /tmp/install_$$.sh; chmod 755 /tmp/install_$$.sh; /tmp/install_$$.sh',
+ command => 'curl http://npmjs.org/install.sh | sed "s/<\/dev\/tty//g" > /tmp/install_$$.sh; chmod 755 /tmp/install_$$.sh; /tmp/install_$$.sh',
unless => 'which npm',
path => $::path,
logoutput => 'on_failure',
View
2 tests/npm.pp
@@ -1,6 +1,6 @@
include 'nodejs'
nodejs::npm { '/tmp/npm:express':
- ensure => present,
+ ensure => present,
version => '2.5.9',
}

0 comments on commit 4b75cc3

Please sign in to comment.