Skip to content
This repository has been archived by the owner. It is now read-only.
1917a35
Compare
Choose a tag to compare

Full Changelog

Fixed bugs:

  • Logging doesn't appear to be working anymore. #146
  • Loglevel is not configureable anymore #140

Merged pull requests:

4a81e76
Compare
Choose a tag to compare

Full Changelog

New

  • APT repository now supports Ubuntu 20.04
  • Ubuntu 20.04 Debian package available for download

Fixed bugs:

  • ArgumentError - wrong number of arguments (given 1, expected 2) #136
  • puppet-webhook 2.1.1 runs in development mode #131
  • Fix a parser issue with the module endpoint #137 (dhollinger)
  • Bugfix: Run Puma in production mode #135 (bastelfreak)

Closed issues:

  • Update r10k gem to 3.4.1 #121
065ef4b
Compare
Choose a tag to compare

Full Changelog

Merged pull requests:

2f07117
Compare
Choose a tag to compare

v2.1.0 (2020-03-09)

Full Changelog

Implemented enhancements:

  • Add Warden and enforce token auth #82
  • Update tests to use WebMock instead of Rack::Test #72
  • Remove Puppet Server Requirement #70

Closed issues:

  • Breaks on Ruby 2.4 #104

Merged pull requests:

1cf09c5
Compare
Choose a tag to compare

Enhancements

  • [enhancement] Async routes #49
  • [backwards-incompatible][enhancement] MVC Rework #83
  • [enhancement] Add tests to validate posts to the module route #37
  • [enhancement] (#puppethack) Add cli binary #40
  • [enhancement] Rocketchat plugin #53
  • [enhancement] ChatOps Plugin Support #52
  • [enhancement] Add additional Slack options. #50
  • [enhancement] Allow github to send form-urlencoded payloads and bug fix in webrick_opts #45

Bug Fixes

  • [bug] Fix a http body param bug #88
  • [bug] Ensure that the ssl cert/key content is sent to WEBrick, not the path #84
  • [bug] Change webrick log constants to strings to match conf file #80

Security

  • [dependencies] Bump puma from 4.3.3 to 4.3.5 #125
  • [dependencies] Bump nokogiri from 1.10.2 to 1.10.5 #105
  • [dependencies] Bump puma from 3.12.1 to 3.12.2 #108
  • [dependencies] Bump rack from 2.0.6 to 2.0.8 #109

Backwards Incompatible

  • [backwards-incompatible] Add sidekiq support with puppet and r10k libs #96
9072559
Compare
Choose a tag to compare