Permalink
Browse files

Secure parameter must be bool in some PHP versions

git-svn-id: https://adminer.svn.sourceforge.net/svnroot/adminer/trunk@1280 7c3ca157-0c34-0410-bff1-cbf682f78f5c
  • Loading branch information...
jakubvrana
jakubvrana committed Dec 18, 2009
1 parent b69ae2f commit 1bcee1ebadf90ec38cfaffb6e9675fef87092454
Showing with 1 addition and 1 deletion.
  1. +1 −1 adminer/include/bootstrap.inc.php
@@ -46,7 +46,7 @@
session_write_close(); // disable session.auto_start
@ini_set("session.use_trans_sid", false); // protect links in export, @ - may be disabled
session_name("adminer_sid"); // use specific session name to get own namespace
-$params = array(0, preg_replace('~\\?.*~', '', $_SERVER["REQUEST_URI"]), "", $_SERVER["HTTPS"]);
+$params = array(0, preg_replace('~\\?.*~', '', $_SERVER["REQUEST_URI"]), "", (bool) $_SERVER["HTTPS"]);
if (version_compare(PHP_VERSION, '5.2.0') >= 0) {
$params[] = true; // HttpOnly
}

0 comments on commit 1bcee1e

Please sign in to comment.