Was unable to build on Linux #1

Closed
dventimi opened this Issue Mar 12, 2011 · 6 comments

2 participants

@dventimi

Hello,
First off, it looks like you've put together a terrific pdf differencing tool and I can't wait to get it working. However, I confess I was not able to build it. I'm using Ubuntu (Karmic) Linux. First the README says to do the usual ./configure ; make ; make install', however the repository doesn't seem to include the configure script. So, I ranautoreconf' and got one. That script was runnable, but it would fail for lack of a Makefile.in, and configure wouldn't make one. I took out the AM_MAINTAINER_MODE macro and reran autoreconf', but then it complained about a missing NEWS and ChangeLog files. Aftertouch NEWS ChangeLog', I was able to get a configure script and a Makefile. Unfortunately, `make' bombed with:

diff-pdf.cpp: In function ‘int main(int, char)’:
diff-pdf.cpp:829: error: no matching function for call to ‘wxInitializer::wxInitializer(int&, char
&)’
/usr/include/wx-2.8/wx/init.h:76: note: candidates are: wxInitializer::wxInitializer(int, wxChar**)
/usr/include/wx-2.8/wx/init.h:73: note: wxInitializer::wxInitializer(const wxInitializer&)

I have wxWidgets 2.8, by the way, and the configure script seemed to pass all the tests.

I'll take a look at it and see if I can coax a working build out of it on my system. Just wanted to let you know. Thanks! Cheers.

@vslavik
Owner

You simply have to run the ./bootstrap script -- this is common practice with autotools-based builds. Anyway, thanks, I added a note about it to README.

I'll have a look at wx-2.8 compilation errors shortly. As a quick fix, you can use wx 2.9 or 2.8 in ANSI configuration.

@vslavik
Owner

I updated the checks to require wx >= 2.8.11 (where this ctor form was added), I don't think it's worth working around for older wx versions. (Just to be clear, I'd accept such a patch, I'm just not going to invest the time myself.)

@vslavik
Owner

Clarified the need to bootstrap autotools files.

Closed by 617db40.

@vslavik
Owner

Well, if this is the way things are done - I hope this makes it into the diff-pdf main code

It won't, sorry. Another year later, I consider the bug fixed by requiring wx >= 2.8.11. Should you insist on using an older version (despite 2.8.11 being two years old), I describe a workaround above: just use the ANSI build. If that's still not good enough, I'd accept a clean good patch for 2.8.10 support. But I'm not going to include convoluted piece of code that you clearly copied from somewhere (read: licensing issues) and that duplicates functionality that already exists in wxWidgets. You could have easily done the same using wx's own APIs -- just see its implementation of the other wxInitializer form.

This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment