Permalink
Browse files

Use responsive plugin for stylus

  • Loading branch information...
1 parent 041a218 commit 147afa273e9fb091714ee68b3e7b6db228a6ac77 @vslinko committed Feb 10, 2013
Showing with 5 additions and 1 deletion.
  1. +2 −1 package.json
  2. +3 −0 stack.coffee
View
@@ -1,6 +1,6 @@
{
"name": "rithis-stack",
- "version": "0.0.3",
+ "version": "0.0.4",
"description": "Our web stack: express, mongoose, rithis-crud",
"keywords": ["web", "stack", "express", "mongoose", "crud"],
"author": {
@@ -23,6 +23,7 @@
"connect-coffee-script": "~0.1",
"stylus": "~0.32",
"nib": "~0.9",
+ "stylus-responsive": "~0.0",
"bower": "~0.6"
}
}
View
@@ -10,6 +10,7 @@ fs = require 'fs'
coffeescript = require 'connect-coffee-script'
stylus = require 'stylus'
nib = require 'nib'
+responsive = require 'stylus-responsive'
jade = require 'jade-static'
@@ -23,7 +24,9 @@ module.exports.configure = (directory, name, configurator) ->
compiler.set 'filename', path
compiler.set 'compress', false
compiler.use nib()
+ compiler.use responsive
compiler.import 'nib'
+ compiler.import 'responsive'
# application
app = express()

0 comments on commit 147afa2

Please sign in to comment.