Socket.IO problem #5

Closed
andrefs opened this Issue Nov 15, 2011 · 4 comments

Comments

Projects
None yet
2 participants

andrefs commented Nov 15, 2011

Hi, I have the same problem reported on issue #4. plackup -s Twiggy showmetheshell.psgi outputs:

Twiggy: Accepting connections at http://0.0.0.0:5000/
127.0.0.1 - - [15/Nov/2011:00:36:45 +0000] "GET / HTTP/1.1" 200 2600 "-" "Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.36 Safari/535.7"
127.0.0.1 - - [15/Nov/2011:00:36:45 +0000] "GET /styles.css HTTP/1.1" 200 1436 "http://0.0.0.0:5000/" "Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.36 Safari/535.7"
127.0.0.1 - - [15/Nov/2011:00:36:45 +0000] "GET /jquery.json.js HTTP/1.1" 200 2247 "http://0.0.0.0:5000/" "Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.36 Safari/535.7"
127.0.0.1 - - [15/Nov/2011:00:36:45 +0000] "GET /shell.js HTTP/1.1" 200 3130 "http://0.0.0.0:5000/" "Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.36 Safari/535.7"
127.0.0.1 - - [15/Nov/2011:00:36:45 +0000] "GET /socket.io/socket.io.js HTTP/1.1" 404 9 "http://0.0.0.0:5000/" "Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.36 Safari/535.7"
127.0.0.1 - - [15/Nov/2011:00:36:45 +0000] "GET /jquery.js HTTP/1.1" 200 72174 "http://0.0.0.0:5000/" "Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.36 Safari/535.7"
127.0.0.1 - - [15/Nov/2011:00:36:46 +0000] "GET /favicon.ico HTTP/1.1" 404 9 "-" "Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.36 Safari/535.7"

However, running git submodule update --init does not fix the problem:

Submodule 'contrib/socket.io' (https://github.com/LearnBoost/Socket.IO) registered for path 'contrib/socket.io'
Cloning into contrib/socket.io...
fatal: https://github.com/LearnBoost/Socket.IO/info/refs not found: did you run git update-server-info on the server?
Clone of 'https://github.com/LearnBoost/Socket.IO' into submodule path 'contrib/socket.io' failed

I guess the problem is that the directory tree in https://github.com/LearnBoost/Socket.IO has changed, I don't see any contrib/scoket.io in there...
Any quick way to fix this?

Thanks

andré

Owner

vti commented Nov 15, 2011

Yes, Socket.IO has moved to Socket.io-client. Also there are some backwards incompatibilities. Give me couple days to fix this :)

andrefs commented Nov 15, 2011

Great, thank you very much :)

@vti vti added a commit that referenced this issue Nov 15, 2011

@vti vti Moved to PocketIO. Closes #GH-5 5c56e0c
Owner

vti commented Nov 15, 2011

It kinda works. INSTALL instructions were changed too.

andrefs commented Nov 15, 2011

Yup, working fine here. Thanks for the quick fix!

andrefs closed this Nov 15, 2011

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment