Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

npm install -g @vue/cli npm WARN #3925

Closed
jquery2005 opened this issue May 1, 2019 · 1 comment

Comments

Projects
None yet
2 participants
@jquery2005
Copy link

commented May 1, 2019

Version

3.7.0

Reproduction link

#516

Environment info

Environment Info:

  System:
    OS: Windows 10
    CPU: (8) x64 Intel(R) Core(TM) i7-3630QM CPU @ 2.40GHz
  Binaries:
    Node: 10.15.3 - E:\Program Files\nodejs\node.EXE
    Yarn: 1.15.2 - C:\Users\msdn1\AppData\Roaming\npm\yarn.CMD
    npm: 6.4.1 - E:\Program Files\nodejs\npm.CMD
  Browsers:
    Edge: 42.17134.1.0
  npmGlobalPackages:
    @vue/cli: Not Found

Steps to reproduce

PS E:\VueLearning> node -v
v10.15.3
PS E:\VueLearning> npm -v
6.4.1
PS E:\VueLearning> vue info

Environment Info:

System:
OS: Windows 10
CPU: (8) x64 Intel(R) Core(TM) i7-3630QM CPU @ 2.40GHz
Binaries:
Node: 10.15.3 - E:\Program Files\nodejs\node.EXE
Yarn: 1.15.2 - C:\Users\msdn1\AppData\Roaming\npm\yarn.CMD
npm: 6.4.1 - E:\Program Files\nodejs\npm.CMD
Browsers:
Edge: 42.17134.1.0
npmGlobalPackages:
@vue/cli: Not Found

PS E:\CSharp\VueLearning> npm uninstall -g @vue/cli
removed 685 packages in 16.855s
PS E:\VueLearning> npm install -g @vue/cli
npm WARN deprecated joi@14.3.1: This module has moved and is now available at @hapi/joi. Please update your dependencies as this version is no longer maintained an may contain bugs and security issues.
npm WARN deprecated hoek@6.1.3: This module has moved and is now available at @hapi/hoek. Please update your dependencies as this version is no longer maintained an may contain bugs and security issues.
npm WARN deprecated cross-spawn-async@2.2.5: cross-spawn no longer requires a build toolchain, use it instead
PS E:\VueLearning>

What is expected?

no npm WARN deprecated

What is actually happening?

npm WARN deprecated joi@14.3.1: This module has moved and is now available at @hapi/joi. Please update your dependencies as this version is no longer maintained an may contain bugs and security issues.
npm WARN deprecated hoek@6.1.3: This module has moved and is now available at @hapi/hoek. Please update your dependencies as this version is no longer maintained an may contain bugs and security issues.
npm WARN deprecated cross-spawn-async@2.2.5: cross-spawn no longer requires a build toolchain, use it instead

@LinusBorg

This comment has been minimized.

Copy link
Member

commented May 2, 2019

Those are warnings, not errors. And they come from transitive dependencies that we can't influence.

Vue CLI works just fine. Ignore the warnings.

@LinusBorg LinusBorg closed this May 2, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.