New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Blog plugin: category, tag page don't work #881

Open
mAKEkr opened this Issue Sep 28, 2018 · 11 comments

Comments

Projects
None yet
5 participants
@mAKEkr
Contributor

mAKEkr commented Sep 28, 2018

Bug report

Version

v1.0.0-alpha.1

Steps to reproduce

  1. install ulivz/vuepress-blog-example-egoist repository
  2. run development mode(vuepress dev source)
  3. access to tag, category page

What is expected?

displaying category, tags page.

What is actually happening?

404 page displaying.

Other relevant information

testing on ulivz/vuepress-blog-example-egoist repository.

  • Your OS: Windows 10
  • Node.js version: v10.4.1
  • Browser version: Firefox
  • Is this a global or local install? local install
  • Which package manager did you use for the install? npm
@ulivz

This comment has been minimized.

Member

ulivz commented Sep 28, 2018

Can't reproduce it. did you clone the latest repo?

@mAKEkr

This comment has been minimized.

Contributor

mAKEkr commented Sep 28, 2018

@ulivz yes, I clone latest repo, and try to up to date nodejs, but same problem on my environment.
vuepress

https://github.com/mAKEkr/vuepress-blog-akekr
this is my vuepress repository, maybe this help for solve this issue.

@mAKEkr

This comment has been minimized.

Contributor

mAKEkr commented Sep 28, 2018

current check build command, all render complete without error.
category and tag page render complete and don't displaying 404.
this problem still an error occurs on dev command.

@ulivz

This comment has been minimized.

Member

ulivz commented Sep 29, 2018

@mAKEkr Could you check if v1.0.0-alpha.2 works?

@mAKEkr

This comment has been minimized.

Contributor

mAKEkr commented Sep 29, 2018

@ulivz I checked v1.0.0-alpha.2 on my repository, these problem not solved yet, and new error on dev/build script.

windows problem
this error has only displaying on Windows OS environment(Ubuntu 18.08 windows subsystem don't display this error). maybe 19e73d7 this commit effect on my environment.

@ekoeryanto

This comment has been minimized.

Contributor

ekoeryanto commented Sep 29, 2018

I have the same issue,
and fixed with #886

@mAKEkr

This comment has been minimized.

Contributor

mAKEkr commented Oct 4, 2018

category and tag page don't register on page-components.js. maybe this is key of solve this issue.

@zvinless

This comment has been minimized.

zvinless commented Oct 19, 2018

this occurs for me on macOS as well, both with the vuepress-blog-example-egoist (alpha.8) repository and with a simple theme on alpha.13.

@mAKEkr

This comment has been minimized.

Contributor

mAKEkr commented Oct 20, 2018

@zvinless can you try on applied #909 PR? this PR solved my issue.

@zvinless

This comment has been minimized.

zvinless commented Oct 20, 2018

@mAKEkr yeah, the pages get generated properly with that change applied 👍

@amorist

This comment has been minimized.

Contributor

amorist commented Oct 29, 2018

same issue

Your OS: MacOS 10.14
Node.js version: v11.0.0
Browser version: Chrome
Is this a global or local install? local install
Which package manager did you use for the install? npm & yarn

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment