Permalink
Browse files

Update history and version for 1.5.2

  • Loading branch information...
1 parent 9defc03 commit b9a607dd2d1c709545c152e30e4f8f664890b55e @drbrain drbrain committed Feb 10, 2011
Showing with 16 additions and 2 deletions.
  1. +15 −1 History.txt
  2. +1 −1 lib/rubygems.rb
View
@@ -1,4 +1,18 @@
-=== 1.5.1 / 2011-02-09
+=== 1.5.2 / 2011-02-10
+
+NOTE: RubyGems 1.5.0 and 1.5.1 have a broken <tt>gem update --system</tt>.
+
+To upgrade you'll need to use the manual upgrade recipe. Using sudo/su as
+appropriate:
+
+ $ gem install rubygems-update
+ $ update_rubygems
+
+Bug Fixes:
+
+* Fixed <tt>gem update --system</tt>. RubyGems can now update itself again.
+
+=== 1.5.1 / 2011-02-09
Minor Enhancement:
View
@@ -118,7 +118,7 @@ class << Gem
# -The RubyGems Team
module Gem
- RubyGemsVersion = VERSION = '1.5.1'
+ RubyGemsVersion = VERSION = '1.5.2'
##
# Raised when RubyGems is unable to load or activate a gem. Contains the

0 comments on commit b9a607d

Please sign in to comment.