Skip to content

wagtail/wagtailtrans

master
Switch branches/tags
Code

Latest commit

 

Git stats

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Wagtailtrans logo

Build status

Code coverage PyPi version Documentation Status

Wagtail multilanguage module

Support multiple languages for your Wagtail site.

Warning

Wagtailtrans is compatible with 2.10.x and lower. If you want migrate to Wagtail 2.11 and up, and switch to the new native wagtail translation system introduced in version 2.11, you can follow the migration guide written by Christian Haintz of the Carrot & Company. We will accept pull requests to make Wagtailtrans compatible with Wagtail 2.11 and up.

Requirements

  • Python 3.5+
  • Django 2+
  • Wagtail 2.7+

Getting started

Follow our Getting Started guide to start integrating Wagtailtrans.

Documentation

The complete project documentation can be found on Read the Docs

Who's using it?

If you want to see some examples on how Wagtailtrans is running in a production environment you can take a look at the following websites: