Permalink
Browse files

drop py3.3 support, since new txtorcon imports asyncio on py3

py3.3 is pretty rare in the wild anyways
  • Loading branch information...
warner committed May 25, 2017
1 parent 6b4ed71 commit 598ab8b62a1fffe23d08dde066d3a57664555b7b
Showing with 5 additions and 7 deletions.
  1. +0 −2 .appveyor.yml
  2. +1 −0 .travis.yml
  3. +3 −4 README.md
  4. +1 −1 tox.ini
View
@@ -13,8 +13,6 @@ environment:
# http://www.appveyor.com/docs/installed-software#python
- PYTHON: "C:\\Python27"
- PYTHON: "C:\\Python27-x64"
- PYTHON: "C:\\Python33"
- PYTHON: "C:\\Python33-x64"
DISTUTILS_USE_SDK: "1"
- PYTHON: "C:\\Python34"
- PYTHON: "C:\\Python34-x64"
View
@@ -21,4 +21,5 @@ after_success:
- codecov
matrix:
allow_failures:
- python: "3.3"
- python: "nightly"
View
@@ -66,8 +66,7 @@ a bug in pynacl which gets confused when the libsodium runtime is installed
(e.g. `libsodium13`) but not the development package.
Developers can clone the source tree and run `tox` to run the unit tests on
all supported (and installed) versions of python: 2.7, 3.3, 3.4, 3.5, and
3.6.
all supported (and installed) versions of python: 2.7, 3.4, 3.5, and 3.6.
## Motivation
@@ -234,8 +233,8 @@ If this happens, run `pip install -e .[dev]` again.
This library is released under the MIT license, see LICENSE for details.
This library is compatible with python2.7, 3.3, 3.4, 3.5, and 3.6 . It
is probably compatible with py2.6, but the latest Twisted (>=15.5.0) is
This library is compatible with python2.7, 3.4, 3.5, and 3.6 . It is
probably compatible with py2.6, but the latest Twisted (>=15.5.0) is
not.
View
@@ -4,7 +4,7 @@
# and then run "tox" from this directory.
[tox]
envlist = {py27,py33,py34,py35,py36,pypy}
envlist = {py27,py34,py35,py36,pypy}
skip_missing_interpreters = True
minversion = 2.4.0

0 comments on commit 598ab8b

Please sign in to comment.