Permalink
Browse files

setup.py: add dep on attrs, >=16.3.0 to get __attrs_post_init__

I should have added this when I switched to the new state machines, since
they definitely depend on attrs. The only reason this worked at all was that
some subdependency was also depending upon attrs.

We need at least 16.3.0, since we use __attrs_post_init__, and that feature
wasn't included in attrs-16.2.0 or earlier.

Closess #248
  • Loading branch information...
warner committed Sep 3, 2017
1 parent 50a1df3 commit 68ce54ad3a99d412d4886fddc94a5f38a79777d6
Showing with 1 addition and 0 deletions.
  1. +1 −0 setup.py
View
@@ -28,6 +28,7 @@
install_requires=[
"spake2==0.7", "pynacl",
"six",
"attrs >= 16.3.0", # 16.3.0 adds __attrs_post_init__
"twisted[tls] >= 17.5.0", # 17.5.0 adds failAfterFailures=
"autobahn[twisted] >= 0.14.1",
"automat",

0 comments on commit 68ce54a

Please sign in to comment.