Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Hot code loading for node.js

branch: master

Fetching latest commit…

Octocat-spinner-32-eaf2f5

Cannot retrieve the latest commit at this time

Octocat-spinner-32 coffeescript
Octocat-spinner-32 javascript
Octocat-spinner-32 .DS_Store
Octocat-spinner-32 Cakefile
Octocat-spinner-32 README.md
Octocat-spinner-32 package.json
README.md

Hotnode

Hotnode is a package that allows you to automatically reload your code by just saving the source in your editor.

Feature Overview

  • Automatically reloads your node.js code on file change
  • Watches .js files in the current directory and its subdirectories

Installation

The following versions are required for Hotnode:

  • Node.js >= 0.2.2
  • npm >= 0.1.25

To see growl messages as soon as your node.js process has been restarted, you will need http://growl.info/extras.php#growlnotify, a command-line based tool for growl.

For notifications on Ubuntu / Gnome, you need libnotify:

sudo apt-get install libnotify-bin

Install it simply via npm:

npm install hotnode

Instructions

Instead of starting your app directly with node app.js Launch it with hotnode app.js

Hotcoffee

Hotnode also includes an executable called hotcoffee which automatically runs the given file with the coffee command and watches all CoffeeScript files in the directory.

License

Copyright (c) 2010 http://www.filshmedia.net, released under the MIT license

Something went wrong with that request. Please try again.