Permalink
Browse files

Deps update. Fix outdated script

  • Loading branch information...
Thomas101 committed Jun 6, 2018
1 parent c098d07 commit 75dbf675ea0ab2d80a581f8d04fac9b9082fe9b7
@@ -0,0 +1,11 @@
{
"compilerOptions": {
"experimentalDecorators": true
},
"exclude": [
"node_modules",
"src/**/node_modules",
"src/**/**/node_modules",
"bin"
]
}
@@ -61,7 +61,7 @@
"babel-core": "6.26.3",
"babel-loader": "7.1.4",
"babel-plugin-transform-class-properties": "6.24.1",
"babel-plugin-transform-decorators-legacy": "1.3.4",
"babel-plugin-transform-decorators-legacy": "1.3.5",
"babel-plugin-transform-react-remove-prop-types": "0.4.13",
"babel-preset-env": "1.7.0",
"babel-preset-react": "6.24.1",
@@ -86,8 +86,8 @@
"uglifyjs-webpack-plugin": "1.2.5",
"url-loader": "1.0.1",
"uuid": "3.2.1",
"webpack": "4.8.3",
"webpack-cli": "2.1.3",
"webpack": "4.11.1",
"webpack-cli": "3.0.2",
"webpack-notifier": "1.6.0",
"webpack-target-electron-renderer": "0.4.0",
"yargs": "11.0.0"
@@ -7,12 +7,12 @@ const cmds = PACKAGE_DIRS.map((dir) => {
cmd: process.platform === 'win32' ? 'npm.cmd' : 'npm',
args: [
'outdated',
'--save', 'false', '--save-optional' // Makes sure we cover optional deps too
'--save', '--save-optional' // Makes sure we cover optional deps too
],
opts: { stdio: 'inherit', cwd: dir },
prelog: `${Colors.inverse('npm outdated:')} ${dir}`,
ignoreErrors: true
}
})
sequencePromiseSpawn(cmds).catch((e) => process.exit(-1))
sequencePromiseSpawn(cmds).catch((e) => process.exit(-1))
@@ -5,16 +5,16 @@
"repository": "https://github.com/wavebox/waveboxapp",
"description": "Content UI for Wavebox",
"dependencies": {
"@material-ui/core": "1.0.0",
"@material-ui/icons": "1.0.0",
"@material-ui/core": "1.2.0",
"@material-ui/icons": "1.1.0",
"alt": "0.18.6",
"classnames": "2.2.5",
"fbjs": "0.8.16",
"prop-types": "15.6.1",
"react": "16.3.2",
"react": "16.4.0",
"react-activity": "1.2.2",
"react-addons-shallow-compare": "15.6.2",
"react-dom": "16.3.2",
"react-dom": "16.4.0",
"react-portal-tooltip": "2.4.0",
"uuid": "3.2.1"
},
@@ -5,13 +5,13 @@
"repository": "https://github.com/wavebox/waveboxapp",
"description": "Keychain UI for Wavebox",
"dependencies": {
"@material-ui/core": "1.0.0",
"@material-ui/icons": "1.0.0",
"@material-ui/core": "1.2.0",
"@material-ui/icons": "1.1.0",
"prop-types": "15.6.1",
"react": "16.3.2",
"react": "16.4.0",
"react-activity": "1.2.2",
"react-addons-shallow-compare": "15.6.2",
"react-dom": "16.3.2"
"react-dom": "16.4.0"
},
"devDependencies": {
"standard": "11.0.1",
@@ -13,8 +13,8 @@
"@fortawesome/fontawesome-free-regular": "5.0.13",
"@fortawesome/fontawesome-free-solid": "5.0.13",
"@fortawesome/react-fontawesome": "0.0.20",
"@material-ui/core": "1.0.0",
"@material-ui/icons": "1.0.0",
"@material-ui/core": "1.2.0",
"@material-ui/icons": "1.1.0",
"addressparser": "1.0.1",
"alt": "0.18.6",
"appdirectory": "0.1.0",
@@ -31,17 +31,17 @@
"prop-types": "15.6.1",
"qs": "6.5.2",
"querystring": "0.2.0",
"react": "16.3.2",
"react": "16.4.0",
"react-activity": "1.2.2",
"react-addons-shallow-compare": "15.6.2",
"react-color": "2.14.1",
"react-dom": "16.3.2",
"react-dom": "16.4.0",
"react-notification-system": "0.2.17",
"react-portal-tooltip": "2.4.0",
"react-router": "4.2.0",
"react-router-dom": "4.2.2",
"react-scrollspy": "3.3.5",
"react-sortable-hoc": "0.7.2",
"react-sortable-hoc": "0.8.3",
"react-timeago": "4.1.9",
"react-timer-mixin": "0.13.3",
"semver": "5.5.0",
@@ -5,14 +5,14 @@
"repository": "https://github.com/wavebox/waveboxapp",
"description": "Monitor UI for Wavebox",
"dependencies": {
"@material-ui/core": "1.0.0",
"@material-ui/icons": "1.0.0",
"@material-ui/core": "1.2.0",
"@material-ui/icons": "1.1.0",
"alt": "0.18.6",
"fbjs": "0.8.16",
"prop-types": "15.6.1",
"react": "16.3.2",
"react": "16.4.0",
"react-addons-shallow-compare": "15.6.2",
"react-dom": "16.3.2"
"react-dom": "16.4.0"
},
"devDependencies": {
"standard": "11.0.1",
@@ -10,18 +10,18 @@
"@fortawesome/fontawesome-free-regular": "5.0.13",
"@fortawesome/fontawesome-free-solid": "5.0.13",
"@fortawesome/react-fontawesome": "0.0.20",
"@material-ui/core": "1.0.0",
"@material-ui/icons": "1.0.0",
"@material-ui/core": "1.2.0",
"@material-ui/icons": "1.1.0",
"addressparser": "1.0.1",
"alt": "0.18.6",
"classnames": "2.2.5",
"color": "3.0.0",
"fbjs": "0.8.16",
"prop-types": "15.6.1",
"react": "16.3.2",
"react": "16.4.0",
"react-activity": "1.2.2",
"react-addons-shallow-compare": "15.6.2",
"react-dom": "16.3.2",
"react-dom": "16.4.0",
"react-infinite": "0.13.0",
"react-swipeable-views": "0.12.13",
"react-timeago": "4.1.9"

0 comments on commit 75dbf67

Please sign in to comment.