Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Open in New Window menu item not appearing in Office 365 #1074

Closed
atrasatti opened this issue Aug 5, 2019 · 3 comments

Comments

@atrasatti
Copy link

commented Aug 5, 2019

  • Wavebox Version: 4.10.5
  • Operating System & Version: Mac OSX 10.14.5
  • Account type (if applicable): Office 365

Expected & actual behavior
Right click on the service icon on the left toolbar opens a menu, the first two items should be about opening a new window and a new window in this service. For some reason my Office 365 icon doesn't let me do it. Strangely I have Office's calendar as a sub-service icon on the left and there I do see the open new window entry. See screenshot below.

Steps to reproduce
I have office 365 setup as my first service, so listed as first icon on the left. I have Outlook as the default (not sure if these make any difference). I right click and a menu opens. Open new window is not listed.

Is the bug persistent or intermittent?
Persistent

Screenshots
Two screenshots here, one when right clicking on the main service icon and one when clicking on the secondary icon which is calendar for me.

Additional information
I have 8 other service icons on the left and right clicking on any of them shows the "open in new window" and "in this service" menu items.

Right-click on Office 365 service icon

Right-click on calendar icon inside Office 365

@Thomas101

This comment has been minimized.

Copy link
Member

commented Aug 6, 2019

It's because the larger icon produces a menu for the group (which includes all 10 services/tabs), whereas the smaller one is for the individual tab - hence why they're slightly different.

The UX could be a little bit skewed if you've changed the Service Prioritization setting under account settings. Changing this from normal still has some rough edges. I couldn't quite figure out if you'd changed it from the screenshots though...

Screenshot 2019-08-06 at 09 15 09

... would be good to know more about your setup here

@atrasatti

This comment has been minimized.

Copy link
Author

commented Aug 6, 2019

It's because the larger icon produces a menu for the group (which includes all 10 services/tabs), whereas the smaller one is for the individual tab - hence why they're slightly different.

I see, in fact the service icon for Gsuite does the same. I think as a user it's confusing and I don't know why for the main icon for a collection of services I would not need the "open in new window" item.

... would be good to know more about your setup here

I checked and it's the same as your screenshot, "Normal".

Thomas101 added a commit that referenced this issue Aug 8, 2019

@Thomas101

This comment has been minimized.

Copy link
Member

commented Aug 8, 2019

I think as a user it's confusing and I don't know why for the main icon for a collection of services I would not need the "open in new window" item.

Yep, I agree. This has just gone out in 4.11.1

@Thomas101 Thomas101 closed this Aug 8, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.