Skip to content
This repository
tag: 0.0.90
Fetching contributors…

Octocat-spinner-32-eaf2f5

Cannot retrieve contributors at this time

file 87 lines (69 sloc) 3.887 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86

Usage

  rvm Action [Implementation] [Flags] [Options]

Action

  * usage - show this usage information
  use - setup current shell to use a specific ruby version
  info - show information for current ruby
  list - show currently installed versions
  reload - reload rvm source itself (useful after changing rvm source)
  implode - removes all ruby installations it manages, everything in ~/.rvm
  update - upgrades rvm to the latest version.
  reset - remove default and current settings, exit the shell.
              (If you experience odd behavior try this first)
  debug - emit environment & configuration information for *current* ruby

  install - install one or many ruby versions
  uninstall - uninstall one or many ruby versions, leaves their sources
  remove - uninstall one or many ruby versions and remove their sources

  ruby - runs a named ruby file against specified and/or all rubies
  gem - runs a gem command using selected ruby's 'gem'
  rake - runs a rake task against specified and/or all rubies
  tests - runs 'rake test' across selected ruby versions
  specs - runs 'rake spec' across selected ruby versions

  gemdir - switch to gem directory for installation (new login shell)
  srcdir - switch to src directory for the current ruby installation

Implementation

  * ruby - MRI/YARV Ruby (The Standard), defaults to 1.8.6
  jruby - JRuby
  rbx - rubinius
  ree - ruby Enterprise Edition
  mput - shyouhei(mput)'s github repository
  system - use the system ruby (eg. pre-rvm state)
  default - use rvm set default ruby and system if it hasn't been set.

Flags

  --self - with update, updates rvm itself
  --rubygems - with update, updates rubygems for selected ruby
  --default - with ruby select, sets a default ruby for new shells.
  --debug - Toggle debug mode on for very verbose output.
  --force - Force install, removes old install & source before install.
  --all - Used with 'rvm list' to display 'most' available versions.
  --dump - Used with gemset to dump the current ruby's gemset.
  --load - Used with gemset to load a specified gemset file
  --summary - Used with rubydo to print out a summary of the commands run.
  --jit - Used with rubinius install to build with JIT
  --latest - with gemset --dump skips version strings for latest gem.
  --reconfigure - Force ./configure on install even if Makefile already exists.

Options

  -v|--version - Emit rvm version loaded for current shell
  -h|--help - Emit this output and exit
  -l|--level - patch level to use with rvm use / install
     --tag - subersion tag to use
     --rev - repository revision # to use or 'head' for

     --prefix - path for all rvm files (~/.rvm/), with trailing slash!
     --bin - path for binaries to be placed (~/.rvm/bin/)
     --source - src directory to use (~/.rvm/src/)
     --archives - directory for downladed files (~/.rvm/archives/)
  -S - Specify a script file to attempt to load and run (rubydo)
  -e - Execute code from the command line.
  -G|--gems - root gem path to use
  -C|--configure - custom configure options, comma separated
                    default: --enable-shared=true
  --reconfigure - Force installer to re-run configure if already run
  --make - custom make command
  --make-install - custom make install command
  --nice - process niceness (for slow computers, default 0)
  -m|--gem-set - use a named gem set, instead of the default set.
  --rm-gem-set - Remove a named gem set
  --ree-options - Options passed directly to ree's './installer' on the command line.

Resources:

  http://rvm.beginrescueend.com/
  https://www.pivotaltracker.com/projects/26822

Something went wrong with that request. Please try again.