Skip to content
This repository

Rubygems 2.0.3 fails on HEAD w/Ruby 2.0 (undefined method `fu_stream_blksize' for #) #1712

Closed
ahawkins opened this Issue · 8 comments

6 participants

Adam Hawkins Jordon Bedwell Michal Papis Gaurish Sharma Antwan Wimberly Chris Houhoulis
Adam Hawkins
adam at mba in ~/radium/frontend[inbox-finalizing*] rvm install 2.0.0 --autolibs=4
Searching for binary rubies, this might take some time.
No binary rubies available for: osx/10.8/x86_64/ruby-2.0.0-p0.
Continuing with compilation. Please read 'rvm mount' to get more information on binary rubies.
Installing requirements for osx/10.8/x86_64, might require sudo password
Already up-to-date.
Updating certificates in '/usr/local/etc/openssl/cert.pem'.
Doing /usr/local/etc/openssl
cert.pem => 77ee3751.0
Installing Ruby from source to: /Users/adam/.rvm/rubies/ruby-2.0.0-p0, this may take a while depending on your cpu(s)...
ruby-2.0.0-p0 - #downloading ruby-2.0.0-p0, this may take a while depending on your connection...
ruby-2.0.0-p0 - #extracted to /Users/adam/.rvm/src/ruby-2.0.0-p0 (already extracted)
ruby-2.0.0-p0 - #configuring.......................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
ruby-2.0.0-p0 - #compiling...................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
ruby-2.0.0-p0 - #installing .................................................................................................................................
Retrieving rubygems-2.0.3
######################################################################## 100.0%
Extracting rubygems-2.0.3 ...
Removing old Rubygems files...
Installing rubygems-2.0.3 for ruby-2.0.0-p0................................................................................................................................
Error running 'env GEM_PATH=/Users/adam/.rvm/gems/ruby-2.0.0-p0:/Users/adam/.rvm/gems/ruby-2.0.0-p0@global:/Users/adam/.rvm/gems/ruby-2.0.0-p0:/Users/adam/.rvm/gems/ruby-2.0.0-p0@global GEM_HOME=/Users/adam/.rvm/gems/ruby-2.0.0-p0 /Users/adam/.rvm/rubies/ruby-2.0.0-p0/bin/ruby -d /Users/adam/.rvm/src/rubygems-2.0.3/setup.rb --verbose',
please read /Users/adam/.rvm/log/ruby-2.0.0-p0/rubygems.install.log
Installation of rubygems did not complete successfully.
Saving wrappers to '/Users/adam/.rvm/wrappers/ruby-2.0.0-p0'............................................................

ruby-2.0.0-p0 - #adjusting #shebangs for (gem irb erb ri rdoc testrb rake).
ruby-2.0.0-p0 - #importing default gemsets, this may take time.......................
Install of ruby-2.0.0-p0 - #complete 
adam at mba in ~/radium/frontend[inbox-finalizing*] cat /Users/adam/.rvm/log/ruby-2.0.0-p0/rubygems.install.log
[2013-03-22 10:33:58] /Users/adam/.rvm/rubies/ruby-2.0.0-p0/bin/ruby
Exception `LoadError' at /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/2.0.0/rubygems.rb:1073 - cannot load such file -- rubygems/defaults/operating_system
Exception `LoadError' at /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/2.0.0/rubygems.rb:1082 - cannot load such file -- rubygems/defaults/ruby
malloc_limit=1000000000 (8000000)
heap_min_slots=1000000 (10000)
mkdir -p /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0
mkdir -p /Users/adam/.rvm/rubies/ruby-2.0.0-p0/bin
install -c -m 0644 gauntlet_rubygems.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/gauntlet_rubygems.rb
mkdir -p /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems
install -c -m 0644 rubygems/available_set.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/available_set.rb
install -c -m 0644 rubygems/command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/command.rb
install -c -m 0644 rubygems/command_manager.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/command_manager.rb
mkdir -p /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands
install -c -m 0644 rubygems/commands/build_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/build_command.rb
install -c -m 0644 rubygems/commands/cert_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/cert_command.rb
install -c -m 0644 rubygems/commands/check_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/check_command.rb
install -c -m 0644 rubygems/commands/cleanup_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/cleanup_command.rb
install -c -m 0644 rubygems/commands/contents_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/contents_command.rb
install -c -m 0644 rubygems/commands/dependency_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/dependency_command.rb
install -c -m 0644 rubygems/commands/environment_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/environment_command.rb
install -c -m 0644 rubygems/commands/fetch_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/fetch_command.rb
install -c -m 0644 rubygems/commands/generate_index_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/generate_index_command.rb
install -c -m 0644 rubygems/commands/help_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/help_command.rb
install -c -m 0644 rubygems/commands/install_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/install_command.rb
install -c -m 0644 rubygems/commands/list_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/list_command.rb
install -c -m 0644 rubygems/commands/lock_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/lock_command.rb
install -c -m 0644 rubygems/commands/mirror_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/mirror_command.rb
install -c -m 0644 rubygems/commands/outdated_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/outdated_command.rb
install -c -m 0644 rubygems/commands/owner_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/owner_command.rb
install -c -m 0644 rubygems/commands/pristine_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/pristine_command.rb
install -c -m 0644 rubygems/commands/push_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/push_command.rb
install -c -m 0644 rubygems/commands/query_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/query_command.rb
install -c -m 0644 rubygems/commands/rdoc_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/rdoc_command.rb
install -c -m 0644 rubygems/commands/search_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/search_command.rb
install -c -m 0644 rubygems/commands/server_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/server_command.rb
install -c -m 0644 rubygems/commands/setup_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/setup_command.rb
install -c -m 0644 rubygems/commands/sources_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/sources_command.rb
install -c -m 0644 rubygems/commands/specification_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/specification_command.rb
install -c -m 0644 rubygems/commands/stale_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/stale_command.rb
install -c -m 0644 rubygems/commands/uninstall_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/uninstall_command.rb
install -c -m 0644 rubygems/commands/unpack_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/unpack_command.rb
install -c -m 0644 rubygems/commands/update_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/update_command.rb
install -c -m 0644 rubygems/commands/which_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/which_command.rb
install -c -m 0644 rubygems/commands/yank_command.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/commands/yank_command.rb
install -c -m 0644 rubygems/compatibility.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/compatibility.rb
install -c -m 0644 rubygems/config_file.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/config_file.rb
mkdir -p /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/core_ext
install -c -m 0644 rubygems/core_ext/kernel_gem.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_gem.rb
install -c -m 0644 rubygems/core_ext/kernel_require.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb
install -c -m 0644 rubygems/defaults.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/defaults.rb
install -c -m 0644 rubygems/dependency.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/dependency.rb
install -c -m 0644 rubygems/dependency_installer.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/dependency_installer.rb
install -c -m 0644 rubygems/dependency_list.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/dependency_list.rb
install -c -m 0644 rubygems/dependency_resolver.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/dependency_resolver.rb
install -c -m 0644 rubygems/deprecate.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/deprecate.rb
install -c -m 0644 rubygems/doctor.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/doctor.rb
install -c -m 0644 rubygems/errors.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/errors.rb
install -c -m 0644 rubygems/exceptions.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/exceptions.rb
mkdir -p /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/ext
install -c -m 0644 rubygems/ext/builder.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/ext/builder.rb
install -c -m 0644 rubygems/ext/cmake_builder.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/ext/cmake_builder.rb
install -c -m 0644 rubygems/ext/configure_builder.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/ext/configure_builder.rb
install -c -m 0644 rubygems/ext/ext_conf_builder.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/ext/ext_conf_builder.rb
install -c -m 0644 rubygems/ext/rake_builder.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/ext/rake_builder.rb
install -c -m 0644 rubygems/ext.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/ext.rb
install -c -m 0644 rubygems/gem_runner.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/gem_runner.rb
install -c -m 0644 rubygems/gemcutter_utilities.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/gemcutter_utilities.rb
install -c -m 0644 rubygems/indexer.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/indexer.rb
install -c -m 0644 rubygems/install_message.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/install_message.rb
install -c -m 0644 rubygems/install_update_options.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/install_update_options.rb
install -c -m 0644 rubygems/installer.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/installer.rb
install -c -m 0644 rubygems/installer_test_case.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/installer_test_case.rb
install -c -m 0644 rubygems/local_remote_options.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/local_remote_options.rb
install -c -m 0644 rubygems/mock_gem_ui.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/mock_gem_ui.rb
install -c -m 0644 rubygems/name_tuple.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/name_tuple.rb
mkdir -p /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/package
install -c -m 0644 rubygems/package/digest_io.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/package/digest_io.rb
install -c -m 0644 rubygems/package/old.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/package/old.rb
install -c -m 0644 rubygems/package/tar_header.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/package/tar_header.rb
mkdir -p /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/package/tar_reader
install -c -m 0644 rubygems/package/tar_reader/entry.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/package/tar_reader/entry.rb
install -c -m 0644 rubygems/package/tar_reader.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/package/tar_reader.rb
install -c -m 0644 rubygems/package/tar_test_case.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/package/tar_test_case.rb
install -c -m 0644 rubygems/package/tar_writer.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/package/tar_writer.rb
install -c -m 0644 rubygems/package.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/package.rb
install -c -m 0644 rubygems/package_task.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/package_task.rb
install -c -m 0644 rubygems/path_support.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/path_support.rb
install -c -m 0644 rubygems/platform.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/platform.rb
install -c -m 0644 rubygems/psych_additions.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/psych_additions.rb
install -c -m 0644 rubygems/psych_tree.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/psych_tree.rb
install -c -m 0644 rubygems/rdoc.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/rdoc.rb
install -c -m 0644 rubygems/remote_fetcher.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/remote_fetcher.rb
install -c -m 0644 rubygems/request_set.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/request_set.rb
install -c -m 0644 rubygems/requirement.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/requirement.rb
mkdir -p /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/security
install -c -m 0644 rubygems/security/policies.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/security/policies.rb
install -c -m 0644 rubygems/security/policy.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/security/policy.rb
install -c -m 0644 rubygems/security/signer.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/security/signer.rb
install -c -m 0644 rubygems/security/trust_dir.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/security/trust_dir.rb
install -c -m 0644 rubygems/security.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/security.rb
install -c -m 0644 rubygems/server.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/server.rb
install -c -m 0644 rubygems/source.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/source.rb
install -c -m 0644 rubygems/source_list.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/source_list.rb
install -c -m 0644 rubygems/source_local.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/source_local.rb
install -c -m 0644 rubygems/source_specific_file.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/source_specific_file.rb
install -c -m 0644 rubygems/spec_fetcher.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/spec_fetcher.rb
install -c -m 0644 rubygems/specification.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb
install -c -m 0644 rubygems/syck_hack.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/syck_hack.rb
install -c -m 0644 rubygems/test_case.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/test_case.rb
install -c -m 0644 rubygems/test_utilities.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/test_utilities.rb
install -c -m 0644 rubygems/text.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/text.rb
install -c -m 0644 rubygems/uninstaller.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/uninstaller.rb
install -c -m 0644 rubygems/user_interaction.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/user_interaction.rb
install -c -m 0644 rubygems/validator.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/validator.rb
install -c -m 0644 rubygems/version.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/version.rb
install -c -m 0644 rubygems/version_option.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/version_option.rb
install -c -m 0644 rubygems.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems.rb
install -c -m 0644 ubygems.rb /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/ubygems.rb
mkdir -p /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/ssl_certs
install -c -m 0644 rubygems/ssl_certs/AddTrustExternalCARoot.pem /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/ssl_certs/AddTrustExternalCARoot.pem
install -c -m 0644 rubygems/ssl_certs/Entrust_net-Secure-Server-Certification-Authority.pem /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/ssl_certs/Entrust_net-Secure-Server-Certification-Authority.pem
install -c -m 0644 rubygems/ssl_certs/GeoTrust_Global_CA.pem /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/ssl_certs/GeoTrust_Global_CA.pem
install -c -m 0644 rubygems/ssl_certs/VerisignClass3PublicPrimaryCertificationAuthority-G2.pem /Users/adam/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/rubygems/ssl_certs/VerisignClass3PublicPrimaryCertificationAuthority-G2.pem
install -c -m 0755 /var/folders/mc/8z4vqlj93lg8l6005k9g25640000gn/T/gem.77128 /Users/adam/.rvm/rubies/ruby-2.0.0-p0/bin/gem
rm /var/folders/mc/8z4vqlj93lg8l6005k9g25640000gn/T/gem.77128
ERROR:  While executing gem ... (NoMethodError)
    undefined method `fu_stream_blksize' for #<Gem::Commands::SetupCommand:0x007f9e7de3afa8>
Installing RubyGems
Installing gem executable
Michal Papis
Collaborator

this is because of http://bugs.ruby-lang.org/issues/7992 - it seams harmless (@drbrain is it?) although a better error detection / validation of rubygems validation should help

Gaurish Sharma

I get the same error when trying to upgrade

gaurish@gaurish-den:~$ gem --version
1.8.25

gaurish@gaurish-den:~$ gem update --system
GET http://rubygems.org/latest_specs.4.8.gz
302 Moved Temporarily
GET http://production.s3.rubygems.org/latest_specs.4.8.gz
304 Not Modified
Updating rubygems-update
GET http://rubygems.org/specs.4.8.gz
302 Moved Temporarily
GET http://production.s3.rubygems.org/specs.4.8.gz
304 Not Modified
Installing gem rubygems-update-2.0.3
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/.autotest
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/.document
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/History.txt
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/LICENSE.txt
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/MIT.txt
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/Manifest.txt
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/README.rdoc
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/Rakefile
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/UPGRADING.rdoc
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/bin/gem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/bin/update_rubygems
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/hide_lib_for_update/note.txt
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/gauntlet_rubygems.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/available_set.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/command_manager.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/build_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/cert_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/check_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/cleanup_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/contents_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/dependency_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/environment_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/fetch_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/generate_index_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/help_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/install_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/list_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/lock_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/mirror_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/outdated_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/owner_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/pristine_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/push_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/query_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/rdoc_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/search_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/server_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/setup_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/sources_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/specification_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/stale_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/uninstall_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/unpack_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/update_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/which_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/commands/yank_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/compatibility.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/config_file.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/core_ext/kernel_gem.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/core_ext/kernel_require.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/defaults.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/dependency.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/dependency_installer.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/dependency_list.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/dependency_resolver.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/deprecate.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/doctor.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/errors.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/exceptions.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/ext.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/ext/builder.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/ext/cmake_builder.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/ext/configure_builder.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/ext/ext_conf_builder.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/ext/rake_builder.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/gem_runner.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/gemcutter_utilities.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/indexer.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/install_message.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/install_update_options.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/installer.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/installer_test_case.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/local_remote_options.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/mock_gem_ui.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/name_tuple.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/package.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/package/digest_io.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/package/old.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/package/tar_header.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/package/tar_reader.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/package/tar_reader/entry.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/package/tar_test_case.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/package/tar_writer.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/package_task.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/path_support.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/platform.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/psych_additions.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/psych_tree.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/rdoc.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/remote_fetcher.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/request_set.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/requirement.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/security.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/security/policies.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/security/policy.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/security/signer.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/security/trust_dir.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/server.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/source.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/source_list.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/source_local.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/source_specific_file.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/spec_fetcher.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/specification.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/ssl_certs/.document
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/ssl_certs/AddTrustExternalCARoot.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/ssl_certs/Entrust_net-Secure-Server-Certification-Authority.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/ssl_certs/GeoTrust_Global_CA.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/ssl_certs/VerisignClass3PublicPrimaryCertificationAuthority-G2.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/syck_hack.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/test_case.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/test_utilities.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/text.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/uninstaller.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/user_interaction.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/validator.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/version.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/rubygems/version_option.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/lib/ubygems.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/setup.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/alternate_cert.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/alternate_cert_32.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/alternate_key.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/bad_rake.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/bogussources.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/ca_cert.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/child_cert.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/child_cert_32.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/child_key.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/data/gem-private_key.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/data/gem-public_cert.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/data/null-type.gemspec.rz
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/expired_cert.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/fake_certlib/openssl.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/fix_openssl_warnings.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/foo/discover.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/future_cert.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/future_cert_32.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/good_rake.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/grandchild_cert.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/grandchild_cert_32.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/grandchild_key.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/insure_session.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/invalid_issuer_cert.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/invalid_issuer_cert_32.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/invalid_key.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/invalid_signer_cert.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/invalid_signer_cert_32.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/invalidchild_cert.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/invalidchild_cert_32.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/invalidchild_key.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/plugin/exception/rubygems_plugin.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/plugin/load/rubygems_plugin.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/plugin/standarderror/rubygems_plugin.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/private_key.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/public_cert.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/public_cert_32.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/public_key.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/rubygems/commands/crash_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/rubygems_plugin.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/sff/discover.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/simple_gem.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/ssl_cert.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/ssl_key.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_config.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_deprecate.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_available_set.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_command_manager.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_build_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_cert_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_check_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_cleanup_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_contents_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_dependency_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_environment_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_fetch_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_generate_index_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_help_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_install_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_list_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_lock_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_mirror.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_outdated_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_owner_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_pristine_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_push_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_query_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_search_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_server_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_setup_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_sources_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_specification_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_stale_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_uninstall_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_unpack_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_update_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_which_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_commands_yank_command.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_config_file.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_dependency.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_dependency_installer.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_dependency_list.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_dependency_resolver.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_doctor.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_ext_cmake_builder.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_ext_configure_builder.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_ext_ext_conf_builder.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_ext_rake_builder.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_gem_runner.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_gemcutter_utilities.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_indexer.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_install_update_options.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_installer.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_local_remote_options.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_name_tuple.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_package.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_package_old.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_package_tar_header.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_package_tar_reader.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_package_tar_reader_entry.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_package_tar_writer.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_package_task.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_path_support.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_platform.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_rdoc.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_remote_fetcher.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_request_set.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_requirement.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_security.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_security_policy.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_security_signer.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_security_trust_dir.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_server.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_silent_ui.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_source.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_source_list.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_source_local.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_source_specific_file.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_spec_fetcher.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_specification.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_stream_ui.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_text.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_uninstaller.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_validator.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_version.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_gem_version_option.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_kernel.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/test_require.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/wrong_key_cert.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/test/rubygems/wrong_key_cert_32.pem
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/util/CL2notes
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/util/create_certs.rb
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/gems/rubygems-update-2.0.3/.gemtest
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/bin/update_rubygems
/home/gaurish/.rvm/gems/ruby-2.0.0-p0/bin/update_rubygems
Successfully installed rubygems-update-2.0.3
Installing RubyGems 2.0.3
mkdir -p /home/gaurish/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0
mkdir -p /home/gaurish/.rvm/rubies/ruby-2.0.0-p0/bin
Installing RubyGems
install -c -m 0644 ubygems.rb /home/gaurish/.rvm/rubies/ruby-2.0.0-p0/lib/ruby/site_ruby/2.0.0/ubygems.rb
ERROR:  While executing gem ... (NoMethodError)
    undefined method `fu_stream_blksize' for #<Gem::Commands::SetupCommand:0x9b8be70>

$ gem --version
1.8.25

update failed

Jordon Bedwell

This is a known upstream (RubyGems) issue and even though that error happens RubyGems installs (sometimes.) I hope they will fix it in the next version if it hasn't already been fixed on HEAD (since I haven't been paying attention to rubygems.)

Good day :)

Jordon Bedwell envygeeks closed this
Antwan Wimberly
armw4 commented

Gosh...same thing just happened to me.

Jordon Bedwell

Tis a scary message to see at first indeed, but a bit relieving when you realize RubyGems still installed :D

Chris Houhoulis

For me, library detection seemed to trigger the rubygems bug. Manually installing the missing dependencies meant rubygems installed fine.

(The OP's error log is different than the one @gaurish posted, and mine matches the OP.)

The rubygems bug is getting fixed; great. I know we've improved library detection in rvm 1.19 recently as well, and I don't mean to reopen either issue if they've been solved. I just want to say that when I installed the required libraries that rvm 1.19 missed for ruby, I was then able to install rubygems 2.0.3 without error. So rvm's improving library detection might mean the rubygems bug doesn't get triggered.

Unfortunately I can't re-test because I don't have sudo access anymore on the system where the error occurred. But details about the libraries (if needed) are at http://stackoverflow.com/a/15649250/1066093

Jordon Bedwell

@houhoulis Are the required libraries missing in our list of required dependencies or did you just accidentally forget to install them? Wondering which so we can fix it. If it's the former please do open a ticket and we will update our requirements list quick.

Michal Papis
Collaborator

@houhoulis rvm 1.19 also included --verbose flag for rubygems installation and it triggers this bug in ruby => http://bugs.ruby-lang.org/issues/7992

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.