New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Not 100% Compatible with Rails 5 #317

Closed
SylarRuby opened this Issue Aug 31, 2016 · 1 comment

Comments

Projects
None yet
1 participant
@SylarRuby
Copy link

SylarRuby commented Aug 31, 2016

Error:

v = BigDecimal.new("2.11")
v.to_s # see error below

/Users/sylar/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/activesupport-5.0.0.1/lib/active_support/dependencies.rb:301:in `blame_file!': can't modify frozen fatal (RuntimeError)

Spent many hours figuring this out. With a virgin installation of rails 5.0.0.1, without xeroizer gem, I could convert the BigDecimal to string. Once the xeroizer gem is installed, I get error.

Installed with rails 4 (and xeroizer gem), no error because rails 4 is using active support 4; rails 5 is using active support 5. Why is there an issue with xeroizer and active support 5? @waynerobinson

@SylarRuby SylarRuby changed the title Not Compatible with Rails 5 100% Not 100% Compatible with Rails 5 Aug 31, 2016

@SylarRuby

This comment has been minimized.

Copy link
Author

SylarRuby commented Aug 31, 2016

See #282

@SylarRuby SylarRuby closed this Aug 31, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment