Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Package control 3.1.0 is cycling on bz2 upgrade #989

Closed
ilog2000 opened this issue Sep 15, 2015 · 77 comments
Labels

Comments

@ilog2000
Copy link

@ilog2000 ilog2000 commented Sep 15, 2015

Hello,

20 minutes ago started Sublime Text 3 (Build 3083) and got a message that Package control upgraded to v3.1.0. There also came a problem though. I constantly get the next sequence of error messages:

  1. An error occurred while trying to upgrade bz2. Please restart...
  2. The package specified, bz2, is not available.
  3. 1 missing dependency was just installed. Sublime Text should be restarted...
    and repeating all three steps after restart. On step 1 there is an attempt to clean up "\Packages\bz2" so there only "st3_windows_x64" sub-folder and "dependency-metadata.json" file remains.

Windows 7 64-bit

@ilog2000

This comment has been minimized.

Copy link
Author

@ilog2000 ilog2000 commented Sep 15, 2015

Additionally, the "0_package_control_loader.sublime-package" file contains 11 entries of "02-bz2.py" inside (not sure how it's possible to have 11 entries with the same name in archive, maybe Total Commander archive manager is wrong).

@ilog2000

This comment has been minimized.

Copy link
Author

@ilog2000 ilog2000 commented Sep 15, 2015

The issue resolved by deletion of extra 10 ''02-bz2.py" entries from "0_package_control_loader.sublime-package" archive. But it's strange to me how this could happen.

@wbond

This comment has been minimized.

Copy link
Owner

@wbond wbond commented Sep 15, 2015

My guess is that there was an issue detecting that the bz2 package was installed, although I can't really be sure.

@FichteFoll

This comment has been minimized.

Copy link
Contributor

@FichteFoll FichteFoll commented Sep 15, 2015

contains 11 entries of "02-bz2.py" inside

I also encountered this a few months ago when messing with dependency installation, but this issue should have since been resolved due to the dependency detection that has been added. It might be faulty however or these files are a relic from that old PC version.

@wbond wbond added the bug label Sep 15, 2015
@wbond

This comment has been minimized.

Copy link
Owner

@wbond wbond commented Sep 15, 2015

If anyone sees an issue like this, please try one of the following based on your OS:

Linux:

unzip -l ~/.config/sublime-text-3/Installed\ Packages/0_package_control_loader.sublime-package

OS X:

unzip -l ~/Library/Application\ Support/Sublime\ Text\ 3/Installed\ Packages/0_package_control_loader.sublime-package

Windows:

  • Open Windows Explorer
  • Browse to %APPDATA%\Sublime Text 3\Installed Packages\
  • Use 7zip or another archive program to open 0_package_control_loader.sublime-package to list the files
@godzig

This comment has been minimized.

Copy link

@godzig godzig commented Sep 15, 2015

I used wbond's instructions above to open the 0_package_control_loader.sublime-package archive. Changing the filename from 02-bz2.py to 01-bz2.py solved the issue for me.

@Elwin00

This comment has been minimized.

Copy link

@Elwin00 Elwin00 commented Sep 16, 2015

I had this problem. I had two files in Installed Packages folder on (Windows)
0_package_control_loader.sublime-package
0_package_control_loader.sublime-package-new
Then I had several 02-bz2.py inside the first package (the one without -new suffix). The other package had no such files.
Now, after every second application launch, one extra file was added to the package archive.
I deleted all of the 02-bz2.py files except one but it didn't work, it would keep trying to reinstall bz2.
In the end, I inspected those files and noticed, that the new files are always 68 bytes long, but the original one had 69 bytes (compared with ~1 month old backup). The only difference was a new line at the beginning of the file. So this time I kept the file with first line empty and it seems to work.

@danieljl

This comment has been minimized.

Copy link

@danieljl danieljl commented Sep 16, 2015

Same problem here. I've tried 3 suggestions from @ilog2000, @godzig, @Elwin00 but none seems working for me.

@wbond

This comment has been minimized.

Copy link
Owner

@wbond wbond commented Sep 16, 2015

@danieljl Can you post the output I asked for with #989 (comment)?

@chrisburgan

This comment has been minimized.

Copy link

@chrisburgan chrisburgan commented Sep 17, 2015

Having the same issue. Here's the output from the above command run on OSX.

unzip -l ~/Library/Application\ Support/Sublime\ Text\ 3/Installed\ Packages/0_package_control_loader.sublime-package
Archive: /Users/username/Library/Application Support/Sublime Text 3/Installed Packages/0_package_control_loader.sublime-package
Length Date Time Name


  173  01-06-15 14:36   dependency-metadata.json
 1877  01-06-15 14:36   00-package_control.py
   69  01-06-15 14:36   02-bz2.py
   68  09-16-15 15:52   02-bz2.py
   68  09-16-15 17:25   02-bz2.py
   68  09-16-15 21:17   02-bz2.py
   68  09-17-15 10:37   02-bz2.py
   68  09-17-15 10:41   02-bz2.py
   68  09-17-15 10:42   02-bz2.py
   68  09-17-15 10:42   02-bz2.py
   68  09-17-15 10:44   02-bz2.py
   68  09-17-15 10:47   02-bz2.py
   68  09-17-15 10:49   02-bz2.py
   68  09-17-15 10:53   02-bz2.py

 2867                   14 files
@danieljl

This comment has been minimized.

Copy link

@danieljl danieljl commented Sep 17, 2015

@wbond

00-package_control.py
02-bz2.py
dependency-metadata.json
@ndi-root

This comment has been minimized.

Copy link

@ndi-root ndi-root commented Sep 18, 2015

I had same issue but it seems solved it in my case. It's just simple though.
I just closed ST3 then deleted
0_package_control_loader.sublime-package
0_package_control_loader.sublime-package-new
from Installed Packages folder.
Also I deleted bz2 folder from Packages folder.Then started ST3.
First time I got an attention to restart. So I restart it then any errors didn't show up anymore.

@danieljl

This comment has been minimized.

Copy link

@danieljl danieljl commented Sep 18, 2015

@ndi-root Thanks! It worked for me too.

@iodic

This comment has been minimized.

Copy link

@iodic iodic commented Sep 21, 2015

👍 for the solution provided by @ndi-root, worked for me on OSX. Thanks! :)

@aMarCruz

This comment has been minimized.

Copy link

@aMarCruz aMarCruz commented Sep 21, 2015

@ndi-root thanks, worked for me on Win7, 32bits (I need the normal restart only)

@OrKoN

This comment has been minimized.

Copy link

@OrKoN OrKoN commented Sep 22, 2015

@ndi-root thanks. Worked for me on Linux.

@nodesocket

This comment has been minimized.

Copy link

@nodesocket nodesocket commented Sep 22, 2015

@ndi-root awesome that worked. For others, here are the commands to fix on OS X.

cd ~/Library/Application\ Support/Sublime\ Text\ 3/Installed\ Packages
rm -f rm 0_package_control_loader.sublime-package 0_package_control_loader.sublime-package-new
cd ../Packages
rm -rf bz2
@mafredri

This comment has been minimized.

Copy link

@mafredri mafredri commented Sep 23, 2015

Thanks @ndi-root! That fixed it, although I only needed to delete the 0_package_control_loader.sublime-package-files

@ghprod

This comment has been minimized.

Copy link

@ghprod ghprod commented Oct 2, 2015

@ndi-root Thanks its works for me on Freya 32 bit 💃

@phackwer

This comment has been minimized.

Copy link

@phackwer phackwer commented Oct 2, 2015

I removed Package Control, closed Sublime 3, then removed the files and folders indicated @ndi-root, opened Sublime, reinstalled Package Control, restarted Sublime, and only after all that, it worked.

Only removing the indicated files didn't worked. Package Control had to be removed before, and reinstalled at the end.

@emitategh

This comment has been minimized.

Copy link

@emitategh emitategh commented Oct 13, 2015

@ndi-root - It Worked por me! Thank you sir! Ubuntu x64 Sublime 3

@egeerardyn

This comment has been minimized.

Copy link

@egeerardyn egeerardyn commented Oct 15, 2015

@ndi-root Thanks!

@bwangelme

This comment has been minimized.

Copy link

@bwangelme bwangelme commented Oct 17, 2015

@wbond , I solove this questions! Thanks!

@mitoop

This comment has been minimized.

Copy link

@mitoop mitoop commented Oct 22, 2015

The same situation as @ndi-root says , but it doesn't work for me , @godzig it works for me well.

@aborigeno

This comment has been minimized.

Copy link

@aborigeno aborigeno commented Oct 23, 2015

Also for me the @ndi-root solution didn't work, I've changed the file name inside the zipfile to 01-bz2.py as suggested by @godzig and worked
I'm on OS X 10.10

@Meekohi

This comment has been minimized.

Copy link

@Meekohi Meekohi commented Oct 29, 2015

@nodesocket works for me. Thanks!

@glutanimate

This comment has been minimized.

Copy link

@glutanimate glutanimate commented Mar 1, 2016

@AnthonyMichaelc Thanks for writing this. Deleting the 0_package_control_loader.sublime-package files worked for me.

@AnthonyMichaelc

This comment has been minimized.

Copy link

@AnthonyMichaelc AnthonyMichaelc commented Mar 1, 2016

@glutanimate No problem, It was a simple solution to an annoying problem I encountered. If you do the latest update you shouldn't be prompted to with the same issue again but if so this technique should work agian.

@ctf0

This comment has been minimized.

Copy link

@ctf0 ctf0 commented Mar 10, 2016

just had the same thing today for no logical reason, removing 0_package_control_loader.sublime-package did the trick, thanx

@AnthonyMichaelc

This comment has been minimized.

Copy link

@AnthonyMichaelc AnthonyMichaelc commented Mar 10, 2016

@ctf0 No problem it is a simple fix but should stop it from happening again. I have not any of these issues since I did this.

@Marketionist

This comment has been minimized.

Copy link

@Marketionist Marketionist commented Mar 10, 2016

Just got the same problem on Mac OS X, Sublime Text 3, Build 3103.

The solution
Delete 0_package_control_loader.sublime-package, 0_package_control_loader.sublime-package-new files from Installed Packages folder. Then delete bz2 folder from Packages folder. Here is how to do it with one terminal command:

rm -rf ~/Library/Application\ Support/Sublime\ Text\ 3/Installed\ Packages/0_package_control_loader.sublime-package ~/Library/Application\ Support/Sublime\ Text\ 3/Installed\ Packages/0_package_control_loader.sublime-package-new ~/Library/Application\ Support/Sublime\ Text\ 3/Packages/bz2/

Then quit Sublime Text and open it again.

@diegolamanno

This comment has been minimized.

Copy link

@diegolamanno diegolamanno commented Apr 1, 2016

@ndi-root it worked for me too. Awesome!

My error message : 1 missing dependency was just installed. Sublime Text should be restarted, otherwise one or more of the installed packages may not function properly.

On a Macbook OSX 10.11.3

@kelwenzera

This comment has been minimized.

Copy link

@kelwenzera kelwenzera commented Apr 5, 2016

Just giving my feedback.
Same error message here as the first post said ( me @ Windows 8.1 ).

Steps/What I did:

1 - Opened Sublime, uninstalled all plugins (Cut the plugins).
Restarted Sublime. Same error. Closed it.

2 - Opened it again and installed all plugins again (Paste the plugins and closed Sublime right away, didn't let the plugins actually install).

3 - Went to windows explorer, *%APPDATA%\Sublime Text 3\Installed Packages*
It had only two files named "0_package_control_loader.sublime-package" but one had the "-new" at the end. Deleted the "-new" since it was the older timestamped.

4 - Opened Sublime, error is gone, plugins started to get installed again, everything seems to be working fine.

I don't know which steps was really necessary, but I think if you uninstall the plugins, delete the file, and the open it again, it will work.

@trickbz

This comment has been minimized.

Copy link

@trickbz trickbz commented Apr 23, 2016

kelwenzera, just the #3 step helped me. 10x.

@xs47968224

This comment has been minimized.

Copy link

@xs47968224 xs47968224 commented Apr 29, 2016

I had same issue but it seems solved it in my case.
I just used 7zip to unzip "0_package_control_loader.sublime-package" file
@wbond ,thanks, It's helpful

@dlsso

This comment has been minimized.

Copy link

@dlsso dlsso commented May 9, 2016

@ndi-root Thanks, fixed based on your solution.

For others on OSX:
All I needed to do was remove 0_package_control_loader.sublime-package and 0_package_control_loader.sublime-package-new
from ~/Library/Application Support/Sublime Text 3/Installed Packages.

Message will show one more time on the next start, and then is fine after that.

@zgoda

This comment has been minimized.

Copy link

@zgoda zgoda commented May 12, 2016

I get this message then plugin host crashes (linux 64 bit). Procedure described above works ok.

@bramchi

This comment has been minimized.

Copy link

@bramchi bramchi commented May 17, 2016

I did have a similar issue with the backrefs package. Manually deleting it from the Packages directory helped here too, the message showed one more time on the next Sublime restart, but after another Sublime restart it was gone. Sweet! Thanks for the pointers, y'all.

@burdiyan

This comment has been minimized.

Copy link

@burdiyan burdiyan commented May 24, 2016

I had similar issues with backrefs and bz2. Removing these packages solved the issues the same way @bramchi is saying.

@heyjohnsexton

This comment has been minimized.

Copy link

@heyjohnsexton heyjohnsexton commented May 29, 2016

@ndi-root worked for me!

@omargourari

This comment has been minimized.

Copy link

@omargourari omargourari commented Jun 16, 2016

@ndi-root worked for me too
removed the files
started sublime
same error message prompt
restarted
no additional notification

@FichteFoll

This comment has been minimized.

Copy link
Contributor

@FichteFoll FichteFoll commented Jul 26, 2016

Today, this issue occured to me again. I backed up my 0_package_control_loader.sublime-package and 0_package_control_loader.sublime-package-new files so that I will able to reproduce the problem and start investigating in a fix.

@flippingtables

This comment has been minimized.

Copy link

@flippingtables flippingtables commented Aug 31, 2016

I keep getting this as well. Sublime 3 build 3114. Following @ndi-root tip solves the temporarily. But I have seen this issue crop up again after already deleting the files once before.

@wbond

This comment has been minimized.

Copy link
Owner

@wbond wbond commented Sep 12, 2016

The most recent version of Package Control no longer requires the bz2 dependency. Additionally I've solved some issues with updating the 0_package_control_loader.sublime-package file.

Hopefully between the two of these the next version of PC should solve this issue.

@wbond

This comment has been minimized.

Copy link
Owner

@wbond wbond commented Sep 12, 2016

Here is the commit that should hopefully fix the issue: 0cd0b47

@wbond

This comment has been minimized.

Copy link
Owner

@wbond wbond commented Sep 13, 2016

This commit may resolve the issue for some other situations: e8b1001

@wbond

This comment has been minimized.

Copy link
Owner

@wbond wbond commented Sep 20, 2016

This should be resolved by 3.2.0. If you are still seeing issues after upgrading and restarting Sublime Text, please:

  1. Open a new issue
  2. Include a full debug log
@linuodoc

This comment has been minimized.

Copy link

@linuodoc linuodoc commented Mar 11, 2019

Package Control: Installing 1 missing dependency
Package Control: The dependency "paramiko" is either not available on this platform or for this version of Sublime Text
Package Control: Installed missing dependency paramiko
error: Package Control
1 missing dependency was just installed. Sublime Text should be restarted, otherwise one or more of the installed packages may not function properly.
Package Control: No updated packages

this attached annoying error keeps popup every time when launching subtext 3
Please support?
Capture

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
You can’t perform that action at this time.