Skip to content
This repository

There are no packages available for installation #264

Closed
esouto opened this Issue · 9 comments

4 participants

esouto Will Bond Shujinko Brandon Zylstra
esouto

I try the testing version, but still get the same error

Console #########
Package Control: Download Debug
URL: https://sublime.wbond.net/repositories.json
Resolved IP: 50.116.34.243
Timeout: 30
Package Control: Urllib2 Debug Proxy
http_proxy:
https_proxy:
proxy_username:
proxy_password:
Package Control: Urllib2 HTTPS Debug General
Connecting to sublime.wbond.net on port 443
Package Control: Urllib2 HTTPS Debug General
Connecting to sublime.wbond.net on port 443
CA certs file at C:\Users\Eduardo\AppData\Roaming\Sublime Text 2\Packages\Package Control\certs\ca-bundle.crt
Package Control: Error downloading channel. HTTP exception InvalidCertificateException (Host sublime.wbond.net returned an invalid certificate (_ssl.c:480: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed)
) downloading https://sublime.wbond.net/repositories.json.
Package Control: Download Debug
URL: https://sublime.wbond.net/testing/packages.json
Resolved IP: 50.116.34.243
Timeout: 30
Package Control: Urllib2 Debug Proxy
http_proxy:
https_proxy:
proxy_username:
proxy_password:
Package Control: Urllib2 HTTPS Debug General
Connecting to sublime.wbond.net on port 443
Package Control: Urllib2 HTTPS Debug General
Connecting to sublime.wbond.net on port 443
CA certs file at C:\Users\Eduardo\AppData\Roaming\Sublime Text 2\Packages\Package Control\certs\ca-bundle.crt
Package Control: Error downloading repository. HTTP exception InvalidCertificateException (Host sublime.wbond.net returned an invalid certificate (_ssl.c:480: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed)
) downloading https://sublime.wbond.net/testing/packages.json.
error: Package Control: There are no packages available for installation.

Setting #########
"repository_channels": [
"https://sublime.wbond.net/repositories.json"
],

// A list of URLs that contain a packages JSON file. These repositories
// are placed in order before repositories from the "repository_channels"
// setting
"repositories": [],

"certs": {
    "sublime.wbond.net": ["7f4f8622b4fd001c7f648e09aae7edaa", ""]
},

Seems that it have a problem with the certification.
If I change the "https" for "http" the package control not list all installations and it is not able to upgrade itself.

I need to solve it.
Thanks

Will Bond
Owner

Please check your anti-virus and firewall software. Almost certainly one of the two of those is messing with the connection for the sublime_text binary. You can try checking to see if it has been black-listed, or you can explicitly white-list it.

You can confirm that the SSL certificate is correct by opening https://sublime.wbond.net/repositories.json in your browser.

esouto

Hi, I add to allowed list in my firewall and antovirus (nod32) the following addresses:
https://sublime.wbond.net/repositories.json
https://sublime.wbond.net/testing/packages.json

I disable the firewall to.
I have the same problem.
And, yes I can access the repository from my browser.

Thanks for the reply

Shujinko

I to have this problem, says loading repository and then nothing.

Shujinko

here is the error I get from the console
Exception in thread Thread-3:
Traceback (most recent call last):
File ".\threading.py", line 532, in bootstrap_inner
File ".\Package Control.py", line 3783, in run
File ".\Package Control.py", line 3599, in make_package_list
File ".\Package Control.py", line 2210, in incoming
File ".\Package Control.py", line 2088, in execute
File ".\subprocess.py", line 633, in __init

File ".\subprocess.py", line 842, in _execute_child
WindowsError: [Error 2] The system cannot find the file specified

so what file is it looking for?

Shujinko

found the problem shell=True is missing from the popen call.

Line 808 add as last parameter shell=True

That appears to fix the load issue no idea if the fix is needed elsewhere or not.

Will Bond
Owner

@Shujinko It sounds like you have a different problem, can you open a separate issue?

Will Bond
Owner

@esouto Can you try whitelisting sublime_text.exe?

esouto

thanks @wbond the firewall was scanning the old ssl connections that use 2.0 protocols and blocking it.

esouto esouto closed this
Brandon Zylstra

I'm having similar problems... I'll open a separate issue

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.