Quadstore Compatibility

amatteini edited this page Feb 27, 2013 · 2 revisions

We have tested LDIF’s SPARQL Output Module against the following quadstores:

Product SPARQL Update Version 1 Query URL Request 2 Configuration
AllegroGraph 4.4 1.1 http://host:10035/repositories/repository-name URL-encoded POST + update
<sparql>
 <endpointURI>
   http://host:10035/repositories
   /repository-name
 </endpointURI>
 <queryParameter>update</queryParameter>
 <sparqlVersion>1.1</sparqlVersion>
 <useDirectPost>false</useDirectPost>
</sparql>
OpenLink Virtuoso 6.01 1.0 http://host:8890/sparql/ URL-encoded POST + query
<sparql>
 <endpointURI>
   http://host:8890/sparql/
 </endpointURI>
 <queryParameter>query</queryParameter>
 <sparqlVersion>1.0</sparqlVersion>
 <useDirectPost>false</useDirectPost>
</sparql>
Fuseki 0.2.1 1.1 http://host:3030/dataset-name/update Direct POST
<sparql>
 <endpointURI>
   http://host:3030/dataset-name/update
 </endpointURI>
 <sparqlVersion>1.1</sparqlVersion>
 <useDirectPost>true</useDirectPost>
</sparql>
OpenRDF Sesame 2.6.3 1.1 http://host:8080/openrdf-sesame/repositories/repository-name/statements URL-encoded POST + update
<sparql>
 <endpointURI>
   http://host:8080/openrdf-sesame
   /repositories/repository-name/statements
 </endpointURI>
 <queryParameter>update</queryParameter>
 <sparqlVersion>1.1</sparqlVersion>
 <useDirectPost>false</useDirectPost>
</sparql>
Ontoprise Triple Store Connector 1.70 1.0 http://host:8092/sparul URL-encoded POST + command
<sparql>
 <endpointURI>
   http://host:8092/sparul
 </endpointURI>
 <queryParameter>command</queryParameter>
 <sparqlVersion>1.0</sparqlVersion>
 <useDirectPost>false</useDirectPost>
</sparql>

1 See SPARQL Update – W3C Member Submission (1.0) and SPARQL Update – W3C Member Submission (1.1).

2 The SPARQL 1.1 Protocol Working Draft standardizes this as update.


Notes

  • AllegroGraph public AMIs are available here
  • AllegroGraph 4.4 doesn’t support direct POST requests: Error Message: 'INVALID PARAMETERS: Must specify query or update.'
  • Sesame 2.6.3 doesn’t support direct POST requests: Error Message: 'Unsupported MIME type: application/sparql-update'