Permalink
Browse files

configure needs a dependency on VERSION.

git-svn-id: https://svn.r-project.org/R/trunk@17924 00db46b3-68df-0310-9c12-caf00c1e9a41
  • Loading branch information...
1 parent b9b3d20 commit 530510ddff78a5c1fa654232f5a1b96aa91ac894 hornik committed Jan 22, 2002
Showing with 2 additions and 1 deletion.
  1. +2 −1 Makefile.in
View
@@ -40,9 +40,10 @@ ACINCLUDE_DEPENDENCIES = \
m4/gnome.m4 \
m4/libglade.m4 \
m4/libtool.m4
+CONFIGURE_DEPENDENCIES = $(srcdir)/VERSION
config.status: $(srcdir)/configure
@$(SHELL) ./config.status --recheck
-$(srcdir)/configure: @MAINTAINER_MODE_TRUE@ $(srcdir)/configure.ac $(ACLOCAL_M4)
+$(srcdir)/configure: @MAINTAINER_MODE_TRUE@ $(srcdir)/configure.ac $(ACLOCAL_M4) $(CONFIGURE_DEPENDENCIES)
@cd $(srcdir) && $(AUTOCONF)
$(ACLOCAL_M4): @MAINTAINER_MODE_TRUE@ $(srcdir)/configure.ac $(ACLOCAL_DEPENDENCIES)
@cd $(srcdir) && $(ACLOCAL)

0 comments on commit 530510d

Please sign in to comment.