Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

A mirror of Shish's official Shimmie code

branch: master

Fetching latest commit…

Octocat-spinner-32-eaf2f5

Cannot retrieve the latest commit at this time

Octocat-spinner-32 contrib
Octocat-spinner-32 core
Octocat-spinner-32 ext
Octocat-spinner-32 lib
Octocat-spinner-32 themes
Octocat-spinner-32 .gitignore
Octocat-spinner-32 .htaccess
Octocat-spinner-32 README.txt
Octocat-spinner-32 doxygen.conf
Octocat-spinner-32 favicon.ico
Octocat-spinner-32 index.php
Octocat-spinner-32 install.php
README.txt
          _________.__    .__                .__       ________  
         /   _____/|  |__ |__| _____   _____ |__| ____ \_____  \ 
         \_____  \ |  |  \|  |/     \ /     \|  |/ __ \ /  ____/ 
         /        \|   Y  \  |  Y Y  \  Y Y  \  \  ___//       \ 
        /_______  /|___|  /__|__|_|  /__|_|  /__|\___  >_______ \
                \/      \/         \/      \/        \/        \/

Shimmie Alpha
~~~~~~~~~~~~~
This code is for people who want to write extensions compatible with the
next version of shimmie. You can run a production site with it if you're
feeling brave, but it's not recommended.

If there is a feature here, and not in the stable branch, that's probably
because the feature doesn't work yet :P


Requirements
~~~~~~~~~~~~
MySQL 4.1+
PHP 5.0+
GD or ImageMagick

There is no PHP4 support, because it lacks many useful features which make
shimmie development easier, faster, and less bug prone. PHP4 is officially
dead, if your host hasn't upgraded to at least 5, I would suggest switching
hosts. I'll even host galleries for free if you can't get hosting elsewhere
for whatever reason~


Installation
~~~~~~~~~~~~
1) Create a blank database
2) Unzip shimmie into a folder on the web host
3) Visit the folder with a web browser
4) Enter the location of the database
5) Click "install". Hopefully you'll end up at the welcome screen; if
   not, you should be given instructions on how to fix any errors~


Upgrade from 2.2.X
~~~~~~~~~~~~~~~~~~
Should be automatic, just unzip into a clean folder and copy across
config.php, images and thumbs folders from the old version. This
includes automatically messing with the database -- back it up first!


Upgrade from earlier versions
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
I very much recommend going via each major release in turn (eg, 2.0.6
-> 2.1.3 -> 2.2.4 -> 2.3.0 rather than 2.0.6 -> 2.3.0). While the basic
database and file formats haven't changed *completely*, it's different
enough to be a pain.


Development Info
~~~~~~~~~~~~~~~~
http://shimmie.shishnet.org/doc/

Please tell me if those docs are lacking in any way, so that they can be
improved for the next person who uses them


Contact
~~~~~~~
#shimmie on Freenode -- IRC
webmaster at shishnet.org -- email
http://redmine.shishnet.org/projects/show/shimmie2 -- bug tracker


Licence
~~~~~~~
All code is GPLv2 unless mentioned otherwise; ie, if you give shimmie to
someone else, you have to give them the source (which should be easy, as PHP
is an interpreted language...). If you want to add customisations to your own
site, then those customisations belong to you, and you can do what you want
with them.



Something went wrong with that request. Please try again.