Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Support library issue #338

Closed
kshitij-sminq opened this issue Apr 18, 2017 · 7 comments

Comments

Projects
None yet
3 participants
@kshitij-sminq
Copy link

commented Apr 18, 2017

I get the following warning when I try to include your library. This issue came up when I updated your library from v2.1.2 to v3.1.3. I tried changing versions and found that this issue comes up on v3.0.0 and above. My support library version is 25.3.1

screenshot from 2017-04-18 12-03-28

@wdullaer

This comment has been minimized.

Copy link
Owner

commented Apr 18, 2017

This project also includes the support library. The versions must match. It looks like you're using an older version.

@kshitij-sminq

This comment has been minimized.

Copy link
Author

commented Apr 18, 2017

I am using v25.3.1 which is the latest stable release at this time

@wdullaer

This comment has been minimized.

Copy link
Owner

commented Apr 18, 2017

I need to release a new version with that version

@kshitij-sminq

This comment has been minimized.

Copy link
Author

commented Apr 19, 2017

Can you make it such that your library dependencies don't affect the projects that use your library?

@wdullaer

This comment has been minimized.

Copy link
Owner

commented Apr 22, 2017

This is really really hard on the jvm.
I'd have to write a custom class loader, adding significant complexity and brittleness.

@DAltena

This comment has been minimized.

Copy link

commented Jul 10, 2017

@kshitij-sminq you can actually avoid this issue by excluding the support libraries in your application's gradle file, like so:

compile ('com.wdullaer:materialdatetimepicker:3.2.2') {
        exclude group: 'com.android.support'
}

@wdullaer do you foresee any issues doing this, or would this maybe be worth including in the readme? It seems to fix the issue on my end.

@wdullaer

This comment has been minimized.

Copy link
Owner

commented Jul 11, 2017

I wasn't aware you could do that with gradle.
Based on the docs this should do the trick.
Of course this puts the burden on the user to ensure that the version of the support library in the app is compatible with this library, but it will be in the majority of the cases.

I'll add this to the FAQ in the readme, and if I ever require a particular version the support library I'll try to explicitly mention it.

@wdullaer wdullaer self-assigned this Jul 11, 2017

@wdullaer wdullaer closed this in 29d317a Jul 12, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.