Skip to content
Commits on Sep 12, 2012
  1. Prepare 0.3.4

    committed Sep 12, 2012
Commits on Sep 8, 2012
  1. @toy
Commits on Jul 24, 2012
  1. Space. The final frontier.

    committed Jul 24, 2012
  2. Actually create links

    committed Jul 24, 2012
  3. Fix broken link

    committed Jul 24, 2012
Commits on Dec 15, 2011
  1. Bump version

    committed Dec 14, 2011
  2. Move require 'rubygems' to bin/grb...

    Requiring rubygems in lib/ is bad, hmmkay?
    committed Dec 14, 2011
Commits on Dec 14, 2011
  1. Merge pull request #5 from rossmeissl/master

    Fix dependency management
    committed Dec 14, 2011
  2. @rossmeissl
  3. @rossmeissl
  4. @rossmeissl

    Do not run Bundler.setup from main library.

    Imagine a typical use case for grb:
    
    * User moves to a project dir (~/myproj)
    * User uses grb (grb create funtimes)
    * grb executes Bundler.setup, which munges Ruby's load path to match myproj's Gemfile.lock
    * grb tries to require "rainbow," which isn't in myproj's Gemfile.lock
    * grb dies
    
    Gem dependencies are better handled by Rubygems during install, and later by Bundler when running against an
    actual app's Gemfile.
    rossmeissl committed Dec 14, 2011
Commits on Dec 7, 2011
  1. Bump version

    committed Dec 6, 2011
  2. Space. The final frontier.

    committed Dec 6, 2011
  3. Bump version

    committed Dec 6, 2011
  4. Merge pull request #1 from sumbach/branch-set-upstream

    Use `git branch --set-upstream` instead of `git config`
    committed Dec 6, 2011
  5. Update readme

    committed Dec 6, 2011
Commits on Dec 6, 2011
  1. Fix warning about gem packaging

    committed Dec 6, 2011
  2. Get rid of rdoc warning

    committed Dec 6, 2011
  3. abort() > crap_out()

    committed Dec 6, 2011
  4. Merge branch 'Florent2/patch-1'

    * Florent2/patch-1:
      --include-dependencies is now default and will be removed in a future version of RubyGems
    committed Dec 6, 2011
  5. Use Bundler

    committed Dec 6, 2011
Commits on Dec 1, 2011
  1. --include-dependencies is now default and will be removed in a future…

    … version of RubyGems
    Florent Guilleux committed Dec 1, 2011
Commits on Nov 12, 2011
  1. Old git warning

    committed Nov 12, 2011
Commits on Apr 3, 2011
  1. @sumbach

    Fix minor typo in help message

    sumbach committed with Jan 16, 2011
  2. Use Rainbow for all rubies

    committed Apr 3, 2011
  3. @sumbach

    Fix tests under ruby 1.9.2

      - must #dup frozen strings for use in Gem::Specification
      - use absolute paths with require since $LOAD_PATH no longer contains '.'
    sumbach committed with Jan 16, 2011
Commits on Jan 16, 2011
  1. @sumbach

    Use `git branch --set-upstream` instead of `git config`

      - The `git config` method did not respect branch.autosetuprebase
      - The --set-upstream option was introduced in git 1.7.0
    sumbach committed Jan 16, 2011
Commits on May 1, 2009
Something went wrong with that request. Please try again.