Ruby1.9.2 support #3

Closed
wants to merge 1 commit into
from

Conversation

Projects
None yet
3 participants
Contributor

sumbach commented Jan 16, 2011

A couple of patches to get tests passing under ruby 1.9.2. I'm using RVM on Mac OSX 10.6.6.

$ ruby -v
ruby 1.8.7 (2010-04-19 patchlevel 253) [i686-darwin10.4.1], MBARI 0x6770, Ruby Enterprise Edition 2010.02

@sumbach sumbach Fix tests under ruby 1.9.2
  - must #dup frozen strings for use in Gem::Specification
  - use absolute paths with require since $LOAD_PATH no longer contains '.'
75cce38
Owner

webmat commented Jan 20, 2011

Hey man, thanks for the pull requests.

I'll look into them at the beginning of February. I'm super busy right now :-)

Mat

Contributor

sumbach commented Jan 21, 2011

No problem, Mat.

suan commented Oct 17, 2011

webmat if you're there, hopefully you can pull this in. I wanna use this gem but the fact that it hasn't been touched since 2008 leaves me a little nervous :)

Owner

webmat commented Oct 18, 2011

ah, yes I'm there. I got distracted there, for a few months. Babies and new houses will do that to ya :-)

I'll try to merge all the pull requests soon-ish.

Owner

webmat commented Dec 7, 2011

This is in the new version, 0.3.1. Sorry I took so long :-)

webmat closed this Dec 7, 2011

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment