Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

chore: remove fibers package #1059

Merged
merged 5 commits into from Jun 20, 2022

Conversation

amareshsm
Copy link
Contributor

@amareshsm amareshsm commented Jun 5, 2022

This PR contains a:

  • bugfix
  • new feature
  • code refactor
  • test update
  • typo fix
  • metadata update

Motivation / Use-Case

Remove fibers

Fibers package is deprecated.
@amareshsm
Copy link
Contributor Author

amareshsm commented Jun 5, 2022

#1058

CHANGELOG.md Outdated Show resolved Hide resolved
@codecov
Copy link

codecov bot commented Jun 5, 2022

Codecov Report

Merging #1059 (7f07bce) into master (8cd2b19) will not change coverage.
The diff coverage is n/a.

@@           Coverage Diff           @@
##           master    #1059   +/-   ##
=======================================
  Coverage   94.33%   94.33%           
=======================================
  Files           5        5           
  Lines         371      371           
  Branches      137      137           
=======================================
  Hits          350      350           
  Misses         19       19           
  Partials        2        2           

Continue to review full report at Codecov.

Legend - Click here to learn more
Δ = absolute <relative> (impact), ø = not affected, ? = missing data
Powered by Codecov. Last update 8cd2b19...7f07bce. Read the comment docs.

CHANGELOG.md Outdated Show resolved Hide resolved
@amareshsm
Copy link
Contributor Author

amareshsm commented Jun 5, 2022

Codecov seems to be failing. I am not able to view line-by-line coverage for the utils file.

image

package.json Outdated
@@ -38,7 +38,6 @@
"dist"
],
"peerDependencies": {
"fibers": ">= 3.1.0",
Copy link
Member

@alexander-akait alexander-akait Jun 5, 2022

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Don't remove it from here, we still need to continue support (otherwise it will be breaking change), just improve readme about deprection

Copy link
Contributor Author

@amareshsm amareshsm Jun 9, 2022

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

sure. I will update readme and revert other changes

Copy link
Contributor Author

@amareshsm amareshsm Jun 9, 2022

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

done. Pls let me know any changes required

@amareshsm
Copy link
Contributor Author

amareshsm commented Jun 17, 2022

Bumping for review.

README.md Outdated
@@ -244,7 +244,8 @@ To avoid this overhead, you can use the [fibers](https://www.npmjs.com/package/f

We automatically inject the [`fibers`](https://github.com/laverdet/node-fibers) package (setup `sassOptions.fiber`) for `Node.js` less v16.0.0 if is possible (i.e. you need install the [`fibers`](https://github.com/laverdet/node-fibers) package).

> Fibers is not compatible with `Node.js` v16.0.0 or later ([see introduction to readme](https://github.com/laverdet/node-fibers)).
> ⚠ Fibers is not compatible with `Node.js` v16.0.0 or later. Unfortunately, v8
> commit [dacc2fee0f](https://github.com/v8/v8/commit/dacc2fee0f815823782a7e432c79c2a7767a4765) is a breaking change and workarounds are non-trivial. ([see introduction to readme](https://github.com/laverdet/node-fibers)).
Copy link
Member

@alexander-akait alexander-akait Jun 18, 2022

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Can we use the latest supported syntax here, i.e.

> **Warning**
>
> Warning Text

Copy link
Contributor Author

@amareshsm amareshsm Jun 19, 2022

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

done

@alexander-akait alexander-akait merged commit cb98ad5 into webpack-contrib:master Jun 20, 2022
13 checks passed
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

3 participants