Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Segmentation fault when import #141

Closed
leroychen opened this Issue · 2 comments

2 participants

@leroychen

I have installed python 2.5.2 on Centos 5.6
(LSB Version: :core-4.0-amd64:core-4.0-ia32:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-ia32:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-ia32:printing-4.0-noarch
)
then i installed openssl and rebuild python 2.5.2 with SSL supported.
when i reinstalled web.py-0.33,install succeed.but i get segmentation fault when import web
[root@9qu python2.5]# python
Python 2.5.2 (r252:60911, Feb 15 2012, 12:10:01)
[GCC 4.1.2 20080704 (Red Hat 4.1.2-51)] on linux2
Type "help", "copyright", "credits" or "license" for more information.

import web
segmentation fault
[root@9qu python2.5]#

and then i want to install web.py-0.36 to see if it works.
but i just get segmentation fault when i run python setup.py install
[root@9qu web.py-0.36]# python setup.py install
segmentation fault
[root@9qu web.py-0.36]#

btw,i have did the same step on another centos 5.4(
LSB Version: :core-3.1-amd64:core-3.1-ia32:core-3.1-noarch:graphics-3.1-amd64:graphics-3.1-ia32:graphics-3.1-noarch
)
and it works well!

who can help me?

@tomthorogood

Are you getting this error just when importing web.py or have you tried using any other packages in Python?

@leroychen

It's my fail.I recompiled python with SSL supported,but I write a wrong configure file.
I have reconfigured it,and recompiled it,It's works!

@leroychen leroychen closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.