npm install fails on node 0.7.10 #83

Closed
gametbt opened this Issue Jun 13, 2012 · 1 comment

Comments

Projects
None yet
2 participants

gametbt commented Jun 13, 2012

npm install ws

ws@0.4.8 preinstall /opt/sites/nodejs/node_modules/ws
make
node-waf configure build
Checking for program g++ or c++ : /usr/bin/g++
Checking for program cpp : /usr/bin/cpp
Checking for program ar : /usr/bin/ar
Checking for program ranlib : /usr/bin/ranlib
Checking for g++ : ok
Checking for node path : not found
Checking for node prefix : ok /usr/local/node-v0.7.10
'configure' finished successfully (0.384s)
Waf: Entering directory /opt/sites/nodejs/node_modules/ws/build' [1/4] cxx: src/validation.cc -> build/Release/src/validation_1.o [2/4] cxx: src/bufferutil.cc -> build/Release/src/bufferutil_2.o [3/4] cxx_link: build/Release/src/validation_1.o -> build/Release/validation.node [4/4] cxx_link: build/Release/src/bufferutil_2.o -> build/Release/bufferutil.node Waf: Leaving directory/opt/sites/nodejs/node_modules/ws/build'
'build' finished successfully (2.853s)
npm ERR! notsup Unsupported
npm ERR! notsup Not compatible with your version of node/npm: commander@0.5.0
npm ERR! notsup Required: {"node":">= 0.4.x < 0.7.0"}
npm ERR! notsup Actual: {"npm":"1.1.25","node":"0.7.10"}

npm ERR! System Linux 2.6.18-308.8.1.el5
npm ERR! command "/usr/local/node-v0.7.10/bin/node" "/usr/local/node/bin/npm" "install" "ws"
npm ERR! cwd /opt/sites/nodejs
npm ERR! node -v v0.7.10
npm ERR! npm -v 1.1.25
npm ERR! code ENOTSUP
npm ERR! message Unsupported
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /opt/sites/nodejs/npm-debug.log
npm ERR! not ok code 0

Contributor

einaros commented Jun 13, 2012

Whatever you are installing depends on an old version of ws. The master is
fully 0.7 compatible.

Fix the dependency, or stick with a stable node version :)
On Jun 13, 2012 5:04 AM, "gametbt" <
reply@reply.github.com>
wrote:

npm install ws

ws@0.4.8 preinstall /opt/sites/nodejs/node_modules/ws
make
node-waf configure build
Checking for program g++ or c++ : /usr/bin/g++
Checking for program cpp : /usr/bin/cpp
Checking for program ar : /usr/bin/ar
Checking for program ranlib : /usr/bin/ranlib
Checking for g++ : ok
Checking for node path : not found
Checking for node prefix : ok /usr/local/node-v0.7.10
'configure' finished successfully (0.384s)
Waf: Entering directory /opt/sites/nodejs/node_modules/ws/build' [1/4] cxx: src/validation.cc -> build/Release/src/validation_1.o [2/4] cxx: src/bufferutil.cc -> build/Release/src/bufferutil_2.o [3/4] cxx_link: build/Release/src/validation_1.o -> build/Release/validation.node [4/4] cxx_link: build/Release/src/bufferutil_2.o -> build/Release/bufferutil.node Waf: Leaving directory/opt/sites/nodejs/node_modules/ws/build'
'build' finished successfully (2.853s)
npm ERR! notsup Unsupported
npm ERR! notsup Not compatible with your version of node/npm:
commander@0.5.0
npm ERR! notsup Required: {"node":">= 0.4.x < 0.7.0"}
npm ERR! notsup Actual: {"npm":"1.1.25","node":"0.7.10"}

npm ERR! System Linux 2.6.18-308.8.1.el5
npm ERR! command "/usr/local/node-v0.7.10/bin/node"
"/usr/local/node/bin/npm" "install" "ws"
npm ERR! cwd /opt/sites/nodejs
npm ERR! node -v v0.7.10
npm ERR! npm -v 1.1.25
npm ERR! code ENOTSUP
npm ERR! message Unsupported
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /opt/sites/nodejs/npm-debug.log
npm ERR! not ok code 0


Reply to this email directly or view it on GitHub:
einaros#83

einaros closed this Jun 13, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment