New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Errors building snap package for Wekan v0.62 #21

Closed
xet7 opened this Issue Dec 13, 2017 · 1 comment

Comments

Projects
None yet
1 participant
@xet7
Copy link
Member

xet7 commented Dec 13, 2017

@kubiko

I am unable to build snap package correctly. I did revert to older MongoDB version, thinking if that was problem, but it still gives some SSL errors:
https://launchpadlibrarian.net/349073984/buildlog_snap_ubuntu_xenial_amd64_wekan-devel_BUILDING.txt.gz

Here is current snapcraft.yml, it still uses Meteor 1.4 and Node 4.x:
https://github.com/wekan/wekan/blob/devel/snapcraft.yaml

I did try to upgrade to Meteor 1.6 and Node 6.12.2, and it did work locally when I built it from source, but changes to snapcraft.yml failed to build:
https://github.com/wekan/wekan/blob/meteor-1.6/snapcraft.yaml

Because with Meteor 1.6 build failed with Docker/Snap/Sandstorm builds then I had to revert back to Meteor 1.4 version to get new Wekan release v0.62 done. Other platforms for Wekan v0.62 are already released, but Snap version is not, because of these errors.

@xet7

This comment has been minimized.

Copy link
Member Author

xet7 commented Dec 19, 2017

I fixed this myself. Wekan v0.62 snap is now released.

@xet7 xet7 closed this Dec 19, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment