Skip to content
文言文編程語言 A programming language for the ancient Chinese.
TypeScript JavaScript HTML CSS
Branch: master
Clone or download
LingDong- Merge pull request #561 from antfu/test/wonton
test: add some tests for wonton
Latest commit 3f3d77e Jan 20, 2020
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
.github docs: update readme for wiki Jan 17, 2020
documentation docs: redirect users from old docs to wiki Jan 17, 2020
examples wonton\!\! Jan 19, 2020
lib Simplified characters to traditional characters. Jan 19, 2020
renders nofont Dec 16, 2019
screenshots ignore prev commit; this is the prev commit Jan 17, 2020
site docs: add legacy site placeholder Jan 7, 2020
src fix: escape double quote Jan 20, 2020
static fix: minor bugs Jan 19, 2020
test test: update tests for wonton Jan 20, 2020
tools Merge branch 'master' of https://github.com/LingDong-/wenyan-lang Jan 19, 2020
.eslintrc.js chore: tslize Jan 15, 2020
.gitattributes re-organize Dec 12, 2019
.gitignore chore: scripts to update wiki Jan 17, 2020
.npmrc add \.npmrc which is necessary to build or test at least for windows Dec 30, 2019
CHANGELOG.md chore: update readme Jan 17, 2020
CNAME cp CNAME Dec 16, 2019
CONTRIBUTING.md docs: add a note to chinese docs. Jan 17, 2020
LICENSE Update LICENSE Jan 1, 2020
Makefile python support, cmdline, more Dec 13, 2019
README.md docs: add contributors badges Jan 20, 2020
README.zh-Hans.md docs: add a note to chinese docs. Jan 17, 2020
README.zh-Hant.md docs: add a note to chinese docs. Jan 17, 2020
jest.config.js fix: test timezone for Windows Jan 17, 2020
package-lock.json chore: add toc for stdlib cheatsheet Jan 17, 2020
package.json chore: add toc for stdlib cheatsheet Jan 17, 2020
tsconfig.json chore: fix tsconfig Jan 17, 2020
webpack.base.config.js chore: d.ts build Jan 15, 2020
webpack.config.js chore: d.ts build Jan 15, 2020
webpack.site.config.js Merge remote-tracking branch 'refs/remotes/origin/master' Jan 17, 2020

README.md

文言 wenyan-lang

npm build Netlify Status

wy-lang.org | Wiki

English | 简体中文 | 繁体中文

文言文編程語言。A programming language for the ancient Chinese. Try it online.

CHANGELOG

之世,結繩而足治,屈指而足算。是時豈料百代之後,計算機械之巧,精於公輸木鳶,善於武侯流馬;程式語言之多,繁若《天官》之星宿,奇勝《山經》之走獸。,或以速稱。,各爭文采。方知鬼之所以夜哭,天之所以雨粟。然以文言編程者 ,似所未有。此誠非文脈之所以傳,文心之所以保。嗟予小子,遂有斯志。然則數寸之烏絲猶覆於頭,萬卷之素書未破於手;一身長羈於遠邦,兩耳久曠于雅言。然夫文章者吾之所宿好,程式者偶承時人之謬譽。故希孟不慚年少,莊生不望無涯。乃作斯言。誠未能嘔瀝長吉心血,亦庶幾免於義山流沫。既成之後,復學干將鑄劍而自飼,越王嚐糞而當先。自謂偶追《十書》之筆意,但恨少八家之淋漓。此子山所謂士衡撫掌而甘心,平子見陋而固宜。然則雖實覆甕之質,尚存斧正之望;雖乏呂相之金,易字之渴蓋同。此亦開源之大義,吾輩之所以勉勵也。一笑。

Helloworld

Wenyan:

吾有一數。曰三。名之曰「甲」。
為是「甲」遍。
	吾有一言。曰「「問天地好在。」」。書之。
云云。

Equivalent JavaScript:

var n = 3;
for (var i = 0; i < n; i++) {
	console.log("問天地好在。");
}

Output:

問天地好在。
問天地好在。
問天地好在。

Punctuations and newlines are completely optional (just like they are in Classical Chinese), so the above code is equivalent to:

吾有一數曰三名之曰「甲」為是「甲」遍吾有一言曰「「問天地好在」」書之云云

More sophisticated examples, such as the Sieve of Eratosthenes, Quicksort, Mandelbrot set, and Tower of Hanoi, can be found in the ./examples folder.

Features

Try it out

The Online IDE

Text Editor Plugins

Command Line Compiler

Install the compiler by

npm install -g @wenyanlang/cli

Try run the included examples, e.g.:

wenyan examples/helloworld.wy
# will outputs: 問天地好在。

The Decompiler

You can now translate JavaScript to wenyan-lang using the wenyanizer by zxch3n.

3rd Party Compilers

Documentation

Check out our Wiki pages

Contributors

Code Contributors

This project exists thanks to all the people who contribute. [Contribute].

Financial Contributors

Become a financial contributor and help us sustain our community. [Contribute]

Individuals

Organizations

Support this project with your organization. Your logo will show up here with a link to your website. [Contribute]

You can’t perform that action at this time.