Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Rails 4.0 Travis setup.

  • Loading branch information...
commit 70dbc52d98e1d397890cd4a2925af711678cc924 1 parent 6d688da
@simi simi authored
View
4 .travis.yml
@@ -2,11 +2,13 @@ rvm:
- 1.8.7
- 1.9.2
- 1.9.3
+ - 2.0.0
- ree
gemfile:
- gemfiles/3.0.gemfile
- gemfiles/3.1.gemfile
- gemfiles/3.2.gemfile
+ - gemfiles/4.0.gemfile
notifications:
recipients:
- - weppos@weppos.net
+ - weppos@weppos.net
View
12 Appraisals
@@ -1,11 +1,15 @@
appraise "3.0" do
- gem "activerecord", "~> 3.0"
+ gem "activerecord", "~> 3.0.0"
end
appraise "3.1" do
- gem "activerecord", "~> 3.1"
+ gem "activerecord", "~> 3.1.0"
end
appraise "3.2" do
- gem "activerecord", "~> 3.2"
-end
+ gem "activerecord", "~> 3.2.0"
+end
+
+appraise "4.0" do
+ gem "activerecord", "~> 4.0.0"
+end
View
8 breadcrumbs_on_rails.gemspec
@@ -9,7 +9,7 @@ Gem::Specification.new do |s|
s.date = "2012-12-25"
s.description = "BreadcrumbsOnRails is a simple Ruby on Rails plugin for creating and managing a breadcrumb navigation for a Rails project."
s.email = "weppos@weppos.net"
- s.files = [".gitignore", ".rvmrc", ".travis.yml", "Appraisals", "CHANGELOG.md", "Gemfile", "LICENSE.txt", "README.md", "Rakefile", "breadcrumbs_on_rails.gemspec", "gemfiles/3.0.gemfile", "gemfiles/3.0.gemfile.lock", "gemfiles/3.1.gemfile", "gemfiles/3.1.gemfile.lock", "gemfiles/3.2.gemfile", "gemfiles/3.2.gemfile.lock", "init.rb", "lib/breadcrumbs_on_rails.rb", "lib/breadcrumbs_on_rails/action_controller.rb", "lib/breadcrumbs_on_rails/breadcrumbs.rb", "lib/breadcrumbs_on_rails/railtie.rb", "lib/breadcrumbs_on_rails/version.rb", "test/dummy.rb", "test/test_helper.rb", "test/unit/action_controller_test.rb", "test/unit/builder_test.rb", "test/unit/element_test.rb", "test/unit/simple_builder_test.rb", "test/views/example/default.html.erb"]
+ s.files = [".gitignore", ".rvmrc", ".travis.yml", "Appraisals", "CHANGELOG.md", "Gemfile", "LICENSE.txt", "README.md", "Rakefile", "breadcrumbs_on_rails.gemspec", "gemfiles/3.0.gemfile", "gemfiles/3.0.gemfile.lock", "gemfiles/3.1.gemfile", "gemfiles/3.1.gemfile.lock", "gemfiles/3.2.gemfile", "gemfiles/3.2.gemfile.lock", "gemfiles/4.0.gemfile", "gemfiles/4.0.gemfile.lock", "init.rb", "lib/breadcrumbs_on_rails.rb", "lib/breadcrumbs_on_rails/action_controller.rb", "lib/breadcrumbs_on_rails/breadcrumbs.rb", "lib/breadcrumbs_on_rails/railtie.rb", "lib/breadcrumbs_on_rails/version.rb", "test/dummy.rb", "test/test_helper.rb", "test/unit/action_controller_test.rb", "test/unit/builder_test.rb", "test/unit/element_test.rb", "test/unit/simple_builder_test.rb", "test/views/example/default.html.erb"]
s.homepage = "http://www.simonecarletti.com/code/breadcrumbs_on_rails"
s.require_paths = ["lib"]
s.rubygems_version = "1.8.24"
@@ -22,18 +22,18 @@ Gem::Specification.new do |s|
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_development_dependency(%q<rails>, [">= 3.0"])
s.add_development_dependency(%q<appraisal>, [">= 0"])
- s.add_development_dependency(%q<mocha>, ["~> 0.9.10"])
+ s.add_development_dependency(%q<mocha>, ["~> 0.14.0"])
s.add_development_dependency(%q<yard>, [">= 0"])
else
s.add_dependency(%q<rails>, [">= 3.0"])
s.add_dependency(%q<appraisal>, [">= 0"])
- s.add_dependency(%q<mocha>, ["~> 0.9.10"])
+ s.add_dependency(%q<mocha>, ["~> 0.14.0"])
s.add_dependency(%q<yard>, [">= 0"])
end
else
s.add_dependency(%q<rails>, [">= 3.0"])
s.add_dependency(%q<appraisal>, [">= 0"])
- s.add_dependency(%q<mocha>, ["~> 0.9.10"])
+ s.add_dependency(%q<mocha>, ["~> 0.14.0"])
s.add_dependency(%q<yard>, [">= 0"])
end
end
View
2  gemfiles/3.0.gemfile
@@ -2,6 +2,6 @@
source "http://rubygems.org"
-gem "activerecord", "~> 3.0"
+gem "activerecord", "~> 3.0.0"
gemspec :path=>"../"
View
135 gemfiles/3.0.gemfile.lock
@@ -1,100 +1,93 @@
PATH
- remote: /Users/weppos/Code/breadcrumbs_on_rails
+ remote: /home/retro/work/fun/breadcrumbs_on_rails
specs:
- breadcrumbs_on_rails (2.1.0)
+ breadcrumbs_on_rails (2.3.0)
GEM
remote: http://rubygems.org/
specs:
- actionmailer (3.2.1)
- actionpack (= 3.2.1)
- mail (~> 2.4.0)
- actionpack (3.2.1)
- activemodel (= 3.2.1)
- activesupport (= 3.2.1)
- builder (~> 3.0.0)
- erubis (~> 2.7.0)
- journey (~> 1.0.1)
- rack (~> 1.4.0)
- rack-cache (~> 1.1)
- rack-test (~> 0.6.1)
- sprockets (~> 2.1.2)
- activemodel (3.2.1)
- activesupport (= 3.2.1)
- builder (~> 3.0.0)
- activerecord (3.2.1)
- activemodel (= 3.2.1)
- activesupport (= 3.2.1)
- arel (~> 3.0.0)
- tzinfo (~> 0.3.29)
- activeresource (3.2.1)
- activemodel (= 3.2.1)
- activesupport (= 3.2.1)
- activesupport (3.2.1)
- i18n (~> 0.6)
- multi_json (~> 1.0)
- appraisal (0.4.0)
+ abstract (1.0.0)
+ actionmailer (3.0.20)
+ actionpack (= 3.0.20)
+ mail (~> 2.2.19)
+ actionpack (3.0.20)
+ activemodel (= 3.0.20)
+ activesupport (= 3.0.20)
+ builder (~> 2.1.2)
+ erubis (~> 2.6.6)
+ i18n (~> 0.5.0)
+ rack (~> 1.2.5)
+ rack-mount (~> 0.6.14)
+ rack-test (~> 0.5.7)
+ tzinfo (~> 0.3.23)
+ activemodel (3.0.20)
+ activesupport (= 3.0.20)
+ builder (~> 2.1.2)
+ i18n (~> 0.5.0)
+ activerecord (3.0.20)
+ activemodel (= 3.0.20)
+ activesupport (= 3.0.20)
+ arel (~> 2.0.10)
+ tzinfo (~> 0.3.23)
+ activeresource (3.0.20)
+ activemodel (= 3.0.20)
+ activesupport (= 3.0.20)
+ activesupport (3.0.20)
+ appraisal (0.5.2)
bundler
rake
- arel (3.0.0)
- builder (3.0.0)
- erubis (2.7.0)
- hike (1.2.1)
- i18n (0.6.0)
- journey (1.0.1)
- json (1.6.5)
- mail (2.4.1)
+ arel (2.0.10)
+ builder (2.1.2)
+ erubis (2.6.6)
+ abstract (>= 1.0.0)
+ i18n (0.5.0)
+ json (1.8.0)
+ mail (2.2.20)
+ activesupport (>= 2.3.6)
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
- mime-types (1.17.2)
- mocha (0.9.12)
- multi_json (1.0.4)
+ metaclass (0.0.1)
+ mime-types (1.23)
+ mocha (0.14.0)
+ metaclass (~> 0.0.1)
polyglot (0.3.3)
- rack (1.4.1)
- rack-cache (1.1)
- rack (>= 0.4)
- rack-ssl (1.3.2)
- rack
- rack-test (0.6.1)
+ rack (1.2.8)
+ rack-mount (0.6.14)
+ rack (>= 1.0.0)
+ rack-test (0.5.7)
rack (>= 1.0)
- rails (3.2.1)
- actionmailer (= 3.2.1)
- actionpack (= 3.2.1)
- activerecord (= 3.2.1)
- activeresource (= 3.2.1)
- activesupport (= 3.2.1)
+ rails (3.0.20)
+ actionmailer (= 3.0.20)
+ actionpack (= 3.0.20)
+ activerecord (= 3.0.20)
+ activeresource (= 3.0.20)
+ activesupport (= 3.0.20)
bundler (~> 1.0)
- railties (= 3.2.1)
- railties (3.2.1)
- actionpack (= 3.2.1)
- activesupport (= 3.2.1)
- rack-ssl (~> 1.3.2)
+ railties (= 3.0.20)
+ railties (3.0.20)
+ actionpack (= 3.0.20)
+ activesupport (= 3.0.20)
rake (>= 0.8.7)
rdoc (~> 3.4)
- thor (~> 0.14.6)
- rake (0.9.2.2)
- rdoc (3.12)
+ thor (~> 0.14.4)
+ rake (10.1.0)
+ rdoc (3.12.2)
json (~> 1.4)
- sprockets (2.1.2)
- hike (~> 1.2)
- rack (~> 1.0)
- tilt (~> 1.1, != 1.3.0)
thor (0.14.6)
- tilt (1.3.3)
- treetop (1.4.10)
+ treetop (1.4.14)
polyglot
polyglot (>= 0.3.1)
- tzinfo (0.3.31)
- yard (0.7.5)
+ tzinfo (0.3.37)
+ yard (0.8.6.2)
PLATFORMS
ruby
DEPENDENCIES
- activerecord (~> 3.0)
+ activerecord (~> 3.0.0)
appraisal
breadcrumbs_on_rails!
- mocha (~> 0.9.10)
+ mocha (~> 0.14.0)
rails (>= 3.0)
yard
View
2  gemfiles/3.1.gemfile
@@ -2,6 +2,6 @@
source "http://rubygems.org"
-gem "activerecord", "~> 3.1"
+gem "activerecord", "~> 3.1.0"
gemspec :path=>"../"
View
118 gemfiles/3.1.gemfile.lock
@@ -1,100 +1,104 @@
PATH
- remote: /Users/weppos/Code/breadcrumbs_on_rails
+ remote: /home/retro/work/fun/breadcrumbs_on_rails
specs:
- breadcrumbs_on_rails (2.1.0)
+ breadcrumbs_on_rails (2.3.0)
GEM
remote: http://rubygems.org/
specs:
- actionmailer (3.2.1)
- actionpack (= 3.2.1)
- mail (~> 2.4.0)
- actionpack (3.2.1)
- activemodel (= 3.2.1)
- activesupport (= 3.2.1)
+ actionmailer (3.1.12)
+ actionpack (= 3.1.12)
+ mail (~> 2.4.4)
+ actionpack (3.1.12)
+ activemodel (= 3.1.12)
+ activesupport (= 3.1.12)
builder (~> 3.0.0)
erubis (~> 2.7.0)
- journey (~> 1.0.1)
- rack (~> 1.4.0)
- rack-cache (~> 1.1)
+ i18n (~> 0.6)
+ rack (~> 1.3.6)
+ rack-cache (~> 1.2)
+ rack-mount (~> 0.8.2)
rack-test (~> 0.6.1)
- sprockets (~> 2.1.2)
- activemodel (3.2.1)
- activesupport (= 3.2.1)
+ sprockets (~> 2.0.4)
+ activemodel (3.1.12)
+ activesupport (= 3.1.12)
builder (~> 3.0.0)
- activerecord (3.2.1)
- activemodel (= 3.2.1)
- activesupport (= 3.2.1)
- arel (~> 3.0.0)
- tzinfo (~> 0.3.29)
- activeresource (3.2.1)
- activemodel (= 3.2.1)
- activesupport (= 3.2.1)
- activesupport (3.2.1)
i18n (~> 0.6)
+ activerecord (3.1.12)
+ activemodel (= 3.1.12)
+ activesupport (= 3.1.12)
+ arel (~> 2.2.3)
+ tzinfo (~> 0.3.29)
+ activeresource (3.1.12)
+ activemodel (= 3.1.12)
+ activesupport (= 3.1.12)
+ activesupport (3.1.12)
multi_json (~> 1.0)
- appraisal (0.4.0)
+ appraisal (0.5.2)
bundler
rake
- arel (3.0.0)
- builder (3.0.0)
+ arel (2.2.3)
+ builder (3.0.4)
erubis (2.7.0)
- hike (1.2.1)
- i18n (0.6.0)
- journey (1.0.1)
- json (1.6.5)
- mail (2.4.1)
+ hike (1.2.3)
+ i18n (0.6.4)
+ json (1.8.0)
+ mail (2.4.4)
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
- mime-types (1.17.2)
- mocha (0.9.12)
- multi_json (1.0.4)
+ metaclass (0.0.1)
+ mime-types (1.23)
+ mocha (0.14.0)
+ metaclass (~> 0.0.1)
+ multi_json (1.7.7)
polyglot (0.3.3)
- rack (1.4.1)
- rack-cache (1.1)
+ rack (1.3.10)
+ rack-cache (1.2)
rack (>= 0.4)
- rack-ssl (1.3.2)
+ rack-mount (0.8.3)
+ rack (>= 1.0.0)
+ rack-ssl (1.3.3)
rack
- rack-test (0.6.1)
+ rack-test (0.6.2)
rack (>= 1.0)
- rails (3.2.1)
- actionmailer (= 3.2.1)
- actionpack (= 3.2.1)
- activerecord (= 3.2.1)
- activeresource (= 3.2.1)
- activesupport (= 3.2.1)
+ rails (3.1.12)
+ actionmailer (= 3.1.12)
+ actionpack (= 3.1.12)
+ activerecord (= 3.1.12)
+ activeresource (= 3.1.12)
+ activesupport (= 3.1.12)
bundler (~> 1.0)
- railties (= 3.2.1)
- railties (3.2.1)
- actionpack (= 3.2.1)
- activesupport (= 3.2.1)
+ railties (= 3.1.12)
+ railties (3.1.12)
+ actionpack (= 3.1.12)
+ activesupport (= 3.1.12)
rack-ssl (~> 1.3.2)
rake (>= 0.8.7)
rdoc (~> 3.4)
thor (~> 0.14.6)
- rake (0.9.2.2)
- rdoc (3.12)
+ rake (10.1.0)
+ rdoc (3.12.2)
json (~> 1.4)
- sprockets (2.1.2)
+ sprockets (2.0.4)
hike (~> 1.2)
rack (~> 1.0)
tilt (~> 1.1, != 1.3.0)
thor (0.14.6)
- tilt (1.3.3)
- treetop (1.4.10)
+ tilt (1.4.1)
+ treetop (1.4.14)
polyglot
polyglot (>= 0.3.1)
- tzinfo (0.3.31)
- yard (0.7.5)
+ tzinfo (0.3.37)
+ yard (0.8.6.2)
PLATFORMS
ruby
DEPENDENCIES
- activerecord (~> 3.1)
+ activerecord (~> 3.1.0)
appraisal
breadcrumbs_on_rails!
- mocha (~> 0.9.10)
+ mocha (~> 0.14.0)
rails (>= 3.0)
yard
View
2  gemfiles/3.2.gemfile
@@ -2,6 +2,6 @@
source "http://rubygems.org"
-gem "activerecord", "~> 3.2"
+gem "activerecord", "~> 3.2.0"
gemspec :path=>"../"
View
122 gemfiles/3.2.gemfile.lock
@@ -1,100 +1,102 @@
PATH
- remote: /Users/weppos/Code/breadcrumbs_on_rails
+ remote: /home/retro/work/fun/breadcrumbs_on_rails
specs:
- breadcrumbs_on_rails (2.1.0)
+ breadcrumbs_on_rails (2.3.0)
GEM
remote: http://rubygems.org/
specs:
- actionmailer (3.2.1)
- actionpack (= 3.2.1)
- mail (~> 2.4.0)
- actionpack (3.2.1)
- activemodel (= 3.2.1)
- activesupport (= 3.2.1)
+ actionmailer (3.2.13)
+ actionpack (= 3.2.13)
+ mail (~> 2.5.3)
+ actionpack (3.2.13)
+ activemodel (= 3.2.13)
+ activesupport (= 3.2.13)
builder (~> 3.0.0)
erubis (~> 2.7.0)
- journey (~> 1.0.1)
- rack (~> 1.4.0)
- rack-cache (~> 1.1)
+ journey (~> 1.0.4)
+ rack (~> 1.4.5)
+ rack-cache (~> 1.2)
rack-test (~> 0.6.1)
- sprockets (~> 2.1.2)
- activemodel (3.2.1)
- activesupport (= 3.2.1)
+ sprockets (~> 2.2.1)
+ activemodel (3.2.13)
+ activesupport (= 3.2.13)
builder (~> 3.0.0)
- activerecord (3.2.1)
- activemodel (= 3.2.1)
- activesupport (= 3.2.1)
- arel (~> 3.0.0)
+ activerecord (3.2.13)
+ activemodel (= 3.2.13)
+ activesupport (= 3.2.13)
+ arel (~> 3.0.2)
tzinfo (~> 0.3.29)
- activeresource (3.2.1)
- activemodel (= 3.2.1)
- activesupport (= 3.2.1)
- activesupport (3.2.1)
- i18n (~> 0.6)
+ activeresource (3.2.13)
+ activemodel (= 3.2.13)
+ activesupport (= 3.2.13)
+ activesupport (3.2.13)
+ i18n (= 0.6.1)
multi_json (~> 1.0)
- appraisal (0.4.0)
+ appraisal (0.5.2)
bundler
rake
- arel (3.0.0)
- builder (3.0.0)
+ arel (3.0.2)
+ builder (3.0.4)
erubis (2.7.0)
- hike (1.2.1)
- i18n (0.6.0)
- journey (1.0.1)
- json (1.6.5)
- mail (2.4.1)
- i18n (>= 0.4.0)
+ hike (1.2.3)
+ i18n (0.6.1)
+ journey (1.0.4)
+ json (1.8.0)
+ mail (2.5.4)
mime-types (~> 1.16)
treetop (~> 1.4.8)
- mime-types (1.17.2)
- mocha (0.9.12)
- multi_json (1.0.4)
+ metaclass (0.0.1)
+ mime-types (1.23)
+ mocha (0.14.0)
+ metaclass (~> 0.0.1)
+ multi_json (1.7.7)
polyglot (0.3.3)
- rack (1.4.1)
- rack-cache (1.1)
+ rack (1.4.5)
+ rack-cache (1.2)
rack (>= 0.4)
- rack-ssl (1.3.2)
+ rack-ssl (1.3.3)
rack
- rack-test (0.6.1)
+ rack-test (0.6.2)
rack (>= 1.0)
- rails (3.2.1)
- actionmailer (= 3.2.1)
- actionpack (= 3.2.1)
- activerecord (= 3.2.1)
- activeresource (= 3.2.1)
- activesupport (= 3.2.1)
+ rails (3.2.13)
+ actionmailer (= 3.2.13)
+ actionpack (= 3.2.13)
+ activerecord (= 3.2.13)
+ activeresource (= 3.2.13)
+ activesupport (= 3.2.13)
bundler (~> 1.0)
- railties (= 3.2.1)
- railties (3.2.1)
- actionpack (= 3.2.1)
- activesupport (= 3.2.1)
+ railties (= 3.2.13)
+ railties (3.2.13)
+ actionpack (= 3.2.13)
+ activesupport (= 3.2.13)
rack-ssl (~> 1.3.2)
rake (>= 0.8.7)
rdoc (~> 3.4)
- thor (~> 0.14.6)
- rake (0.9.2.2)
- rdoc (3.12)
+ thor (>= 0.14.6, < 2.0)
+ rake (10.1.0)
+ rdoc (3.12.2)
json (~> 1.4)
- sprockets (2.1.2)
+ sprockets (2.2.2)
hike (~> 1.2)
+ multi_json (~> 1.0)
rack (~> 1.0)
tilt (~> 1.1, != 1.3.0)
- thor (0.14.6)
- tilt (1.3.3)
- treetop (1.4.10)
+ thor (0.18.1)
+ tilt (1.4.1)
+ treetop (1.4.14)
polyglot
polyglot (>= 0.3.1)
- tzinfo (0.3.31)
- yard (0.7.5)
+ tzinfo (0.3.37)
+ yard (0.8.6.2)
PLATFORMS
ruby
DEPENDENCIES
- activerecord (~> 3.2)
+ activerecord (~> 3.2.0)
appraisal
breadcrumbs_on_rails!
- mocha (~> 0.9.10)
+ mocha (~> 0.14.0)
rails (>= 3.0)
yard
View
7 gemfiles/4.0.gemfile
@@ -0,0 +1,7 @@
+# This file was generated by Appraisal
+
+source "http://rubygems.org"
+
+gem "activerecord", "~> 4.0.0"
+
+gemspec :path=>"../"
View
97 gemfiles/4.0.gemfile.lock
@@ -0,0 +1,97 @@
+PATH
+ remote: /home/retro/work/fun/breadcrumbs_on_rails
+ specs:
+ breadcrumbs_on_rails (2.3.0)
+
+GEM
+ remote: http://rubygems.org/
+ specs:
+ actionmailer (4.0.0)
+ actionpack (= 4.0.0)
+ mail (~> 2.5.3)
+ actionpack (4.0.0)
+ activesupport (= 4.0.0)
+ builder (~> 3.1.0)
+ erubis (~> 2.7.0)
+ rack (~> 1.5.2)
+ rack-test (~> 0.6.2)
+ activemodel (4.0.0)
+ activesupport (= 4.0.0)
+ builder (~> 3.1.0)
+ activerecord (4.0.0)
+ activemodel (= 4.0.0)
+ activerecord-deprecated_finders (~> 1.0.2)
+ activesupport (= 4.0.0)
+ arel (~> 4.0.0)
+ activerecord-deprecated_finders (1.0.3)
+ activesupport (4.0.0)
+ i18n (~> 0.6, >= 0.6.4)
+ minitest (~> 4.2)
+ multi_json (~> 1.3)
+ thread_safe (~> 0.1)
+ tzinfo (~> 0.3.37)
+ appraisal (0.5.2)
+ bundler
+ rake
+ arel (4.0.0)
+ atomic (1.1.10)
+ builder (3.1.4)
+ erubis (2.7.0)
+ hike (1.2.3)
+ i18n (0.6.4)
+ mail (2.5.4)
+ mime-types (~> 1.16)
+ treetop (~> 1.4.8)
+ metaclass (0.0.1)
+ mime-types (1.23)
+ minitest (4.7.5)
+ mocha (0.14.0)
+ metaclass (~> 0.0.1)
+ multi_json (1.7.7)
+ polyglot (0.3.3)
+ rack (1.5.2)
+ rack-test (0.6.2)
+ rack (>= 1.0)
+ rails (4.0.0)
+ actionmailer (= 4.0.0)
+ actionpack (= 4.0.0)
+ activerecord (= 4.0.0)
+ activesupport (= 4.0.0)
+ bundler (>= 1.3.0, < 2.0)
+ railties (= 4.0.0)
+ sprockets-rails (~> 2.0.0)
+ railties (4.0.0)
+ actionpack (= 4.0.0)
+ activesupport (= 4.0.0)
+ rake (>= 0.8.7)
+ thor (>= 0.18.1, < 2.0)
+ rake (10.1.0)
+ sprockets (2.10.0)
+ hike (~> 1.2)
+ multi_json (~> 1.0)
+ rack (~> 1.0)
+ tilt (~> 1.1, != 1.3.0)
+ sprockets-rails (2.0.0)
+ actionpack (>= 3.0)
+ activesupport (>= 3.0)
+ sprockets (~> 2.8)
+ thor (0.18.1)
+ thread_safe (0.1.0)
+ atomic
+ tilt (1.4.1)
+ treetop (1.4.14)
+ polyglot
+ polyglot (>= 0.3.1)
+ tzinfo (0.3.37)
+ yard (0.8.6.2)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ activerecord (~> 4.0.0)
+ appraisal
+ breadcrumbs_on_rails!
+ mocha (~> 0.14.0)
+ rails (>= 3.0)
+ yard
View
2  test/dummy.rb
@@ -8,7 +8,7 @@
class Dummy
Routes = ActionDispatch::Routing::RouteSet.new
Routes.draw do
- match ':controller(/:action(/:id))'
+ match ':controller(/:action(/:id))', via: [:get]
end
end
View
4 test/test_helper.rb
@@ -1,5 +1,5 @@
-require 'test/unit'
-require 'mocha'
+require 'minitest/autorun'
+require 'mocha/setup'
require 'dummy'
$:.unshift File.expand_path('../../lib', __FILE__)
Please sign in to comment.
Something went wrong with that request. Please try again.