Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Add support for rubygems-test.

  • Loading branch information...
commit 0c097aa0a667520ceb722121a7ce5123c989bccd 1 parent 18c7539
Simone Carletti authored
0  .gemtest
View
No changes.
9 Gemfile.lock
View
@@ -1,7 +1,7 @@
PATH
remote: .
specs:
- tabs_on_rails (2.0.0.pre2)
+ tabs_on_rails (2.0.0)
GEM
remote: http://rubygems.org/
@@ -33,7 +33,7 @@ GEM
activemodel (= 3.0.3)
activesupport (= 3.0.3)
activesupport (3.0.3)
- arel (2.0.7)
+ arel (2.0.8)
builder (2.1.2)
erubis (2.6.6)
abstract (>= 1.0.0)
@@ -44,8 +44,7 @@ GEM
mime-types (~> 1.16)
treetop (~> 1.4.8)
mime-types (1.16)
- mocha (0.9.11)
- rake
+ mocha (0.9.12)
polyglot (0.3.1)
rack (1.2.1)
rack-mount (0.6.13)
@@ -77,5 +76,5 @@ PLATFORMS
DEPENDENCIES
bundler
mocha (~> 0.9.10)
- rails (~> 3.0.3)
+ rails (= 3.0.3)
tabs_on_rails!
22 Rakefile
View
@@ -1,17 +1,17 @@
-require "rubygems"
-require "rake/testtask"
-require "rake/gempackagetask"
+require 'rubygems'
+require 'rake/testtask'
+require 'rake/gempackagetask'
begin
- require "hanna/rdoctask"
+ require 'hanna/rdoctask'
rescue LoadError
- require "rake/rdoctask"
+ require 'rake/rdoctask'
end
-$:.unshift(File.dirname(__FILE__) + "/lib")
-require "tabs_on_rails"
+$:.unshift(File.dirname(__FILE__) + '/lib')
+require 'tabs_on_rails/version'
-PKG_NAME = ENV['PKG_NAME'] || TabsOnRails::GEM
+PKG_NAME = ENV['PKG_NAME'] || "tabs_on_rails"
PKG_VERSION = ENV['PKG_VERSION'] || TabsOnRails::VERSION
if ENV['SNAPSHOT'].to_i == 1
@@ -20,7 +20,7 @@ end
# Run test by default.
-task :default => ["test"]
+task :default => :test
# This builds the actual gem. For details of what all these options
# mean, and other ones you can add, check the documentation here:
@@ -46,7 +46,7 @@ spec = Gem::Specification.new do |s|
s.rdoc_options = %w(--main README.rdoc)
# Add any extra files to include in the gem (like your README)
- s.files = %w( Rakefile LICENSE init.rb ) + Dir.glob("*.{rdoc,gemspec}") + Dir.glob("{test,lib,rails}/**/*")
+ s.files = %w( Rakefile LICENSE init.rb .gemtest ) + Dir.glob("*.{rdoc,gemspec}") + Dir.glob("{lib,test,rails}/**/*")
s.require_paths = ["lib"]
# If you want to depend on other gems, add them here, along with any
@@ -55,7 +55,7 @@ spec = Gem::Specification.new do |s|
# If your tests use any gems, include them here
s.add_development_dependency("bundler")
- s.add_development_dependency("rails", "~> 3.0.3")
+ s.add_development_dependency("rails", "3.0.3")
s.add_development_dependency("mocha", "~> 0.9.10")
end
13 tabs_on_rails.gemspec
View
@@ -6,34 +6,33 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Simone Carletti"]
- s.date = %q{2011-02-08}
+ s.date = %q{2011-02-13}
s.description = %q{ TabsOnRails is a simple Ruby on Rails plugin for creating and managing Tabs. It provides helpers for creating tabs with a flexible interface.
}
s.email = %q{weppos@weppos.net}
s.extra_rdoc_files = ["CHANGELOG.rdoc", "README.rdoc"]
- s.files = ["Rakefile", "LICENSE", "init.rb", "CHANGELOG.rdoc", "README.rdoc", "tabs_on_rails.gemspec", "test/tabs_on_rails/controller_mixin_test.rb", "test/tabs_on_rails/tabs/builder_test.rb", "test/tabs_on_rails/tabs/tabs_builder_test.rb", "test/tabs_on_rails/tabs_test.rb", "test/test_helper.rb", "test/views/working/default.html.erb", "test/views/working/with_item_options.html.erb", "test/views/working/with_open_close_tabs.html.erb", "lib/tabs_on_rails/action_controller.rb", "lib/tabs_on_rails/railtie.rb", "lib/tabs_on_rails/tabs/builder.rb", "lib/tabs_on_rails/tabs/tabs_builder.rb", "lib/tabs_on_rails/tabs.rb", "lib/tabs_on_rails/version.rb", "lib/tabs_on_rails.rb"]
+ s.files = ["Rakefile", "LICENSE", "init.rb", "CHANGELOG.rdoc", "README.rdoc", "tabs_on_rails.gemspec", "lib/tabs_on_rails", "lib/tabs_on_rails/action_controller.rb", "lib/tabs_on_rails/railtie.rb", "lib/tabs_on_rails/tabs", "lib/tabs_on_rails/tabs/builder.rb", "lib/tabs_on_rails/tabs/tabs_builder.rb", "lib/tabs_on_rails/tabs.rb", "lib/tabs_on_rails/version.rb", "lib/tabs_on_rails.rb", "test/tabs_on_rails", "test/tabs_on_rails/controller_mixin_test.rb", "test/tabs_on_rails/tabs", "test/tabs_on_rails/tabs/builder_test.rb", "test/tabs_on_rails/tabs/tabs_builder_test.rb", "test/tabs_on_rails/tabs_test.rb", "test/test_helper.rb", "test/views", "test/views/working", "test/views/working/default.html.erb", "test/views/working/with_item_options.html.erb", "test/views/working/with_open_close_tabs.html.erb"]
s.homepage = %q{http://www.simonecarletti.com/code/tabs_on_rails}
s.rdoc_options = ["--main", "README.rdoc"]
s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.7}
+ s.rubygems_version = %q{1.5.2}
s.summary = %q{A simple Ruby on Rails plugin for creating and managing Tabs.}
if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_development_dependency(%q<bundler>, [">= 0"])
- s.add_development_dependency(%q<rails>, ["~> 3.0.3"])
+ s.add_development_dependency(%q<rails>, ["= 3.0.3"])
s.add_development_dependency(%q<mocha>, ["~> 0.9.10"])
else
s.add_dependency(%q<bundler>, [">= 0"])
- s.add_dependency(%q<rails>, ["~> 3.0.3"])
+ s.add_dependency(%q<rails>, ["= 3.0.3"])
s.add_dependency(%q<mocha>, ["~> 0.9.10"])
end
else
s.add_dependency(%q<bundler>, [">= 0"])
- s.add_dependency(%q<rails>, ["~> 3.0.3"])
+ s.add_dependency(%q<rails>, ["= 3.0.3"])
s.add_dependency(%q<mocha>, ["~> 0.9.10"])
end
end
3  test/test_helper.rb
View
@@ -1,6 +1,5 @@
require 'rubygems'
-require 'bundler'
-Bundler.setup
+require 'bundler/setup'
require 'test/unit'
require 'mocha'
Please sign in to comment.
Something went wrong with that request. Please try again.