Skip to content
Browse files

Use Bundler to declare dependencies.

  • Loading branch information...
1 parent e4d471e commit 3a0276a03e9173d73708bd888e98cbbacd79709a @weppos committed Dec 21, 2010
Showing with 48 additions and 10 deletions.
  1. +6 −0 CHANGELOG.rdoc
  2. +6 −0 Gemfile
  3. +31 −0 Gemfile.lock
  4. +2 −2 Rakefile
  5. +3 −8 test/test_helper.rb
View
6 CHANGELOG.rdoc
@@ -1,5 +1,11 @@
= Changelog
+
+== master
+
+* CHANGED: Use Bundler to declare dependencies.
+
+
== Release 1.3.1
* FIXED: Error wrong number of arguments (2 for 3) (closes #3)
View
6 Gemfile
@@ -0,0 +1,6 @@
+source "http://rubygems.org"
+
+group :test do
+ gem "rails", "2.3.5"
+ gem "mocha", "~> 0.9.8"
+end
View
31 Gemfile.lock
@@ -0,0 +1,31 @@
+GEM
+ remote: http://rubygems.org/
+ specs:
+ actionmailer (2.3.5)
+ actionpack (= 2.3.5)
+ actionpack (2.3.5)
+ activesupport (= 2.3.5)
+ rack (~> 1.0.0)
+ activerecord (2.3.5)
+ activesupport (= 2.3.5)
+ activeresource (2.3.5)
+ activesupport (= 2.3.5)
+ activesupport (2.3.5)
+ mocha (0.9.10)
+ rake
+ rack (1.0.1)
+ rails (2.3.5)
+ actionmailer (= 2.3.5)
+ actionpack (= 2.3.5)
+ activerecord (= 2.3.5)
+ activeresource (= 2.3.5)
+ activesupport (= 2.3.5)
+ rake (>= 0.8.3)
+ rake (0.8.7)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ mocha (~> 0.9.8)
+ rails (= 2.3.5)
View
4 Rakefile
@@ -61,15 +61,15 @@ spec = Gem::Specification.new do |s|
s.rdoc_options = %w(--main README.rdoc)
# Add any extra files to include in the gem (like your README)
- s.files = %w(Rakefile init.rb) + Dir.glob("*.{rdoc,gemspec}") + Dir.glob("{test,lib,rails}/**/*")
+ s.files = %w( Rakefile init.rb ) + Dir.glob("*.{rdoc,gemspec}") + Dir.glob("{test,lib,rails}/**/*")
s.require_paths = ["lib"]
# If you want to depend on other gems, add them here, along with any
# relevant versions
# s.add_dependency("some_other_gem", "~> 0.1.0")
# If your tests use any gems, include them here
- # s.add_development_dependency("mocha") # for example
+ s.add_development_dependency("bundler")
end
# This task actually builds the gem. We also regenerate a static
View
11 test/test_helper.rb
@@ -1,12 +1,7 @@
require 'rubygems'
-gem 'rails', '~>2.3.5'
-gem 'mocha', '~>0.9.8'
-
-# Remember! Due to some Mocha internal changes,
-# Rails 2.2.x requires Mocha 0.9.5 and
-# Rails 2.3.x requires Mocha 0.9.7
-# gem 'rails', '2.2.2'
-# gem 'mocha', '0.9.5'
+require 'bundler'
+Bundler.setup(:default, :test)
+
require 'test/unit'
require 'active_support'

0 comments on commit 3a0276a

Please sign in to comment.
Something went wrong with that request. Please try again.