Permalink
Browse files

rspec-core 2.11.1 is not compatible with mocha 0.13.0

Mocha removed mocha/object.
  • Loading branch information...
weppos committed Nov 11, 2012
1 parent ceafb8d commit 13821879ee9c13095d66a14f684ae460016c53b6
Showing with 5 additions and 5 deletions.
  1. +1 −1 Rakefile
  2. +4 −4 whois.gemspec
View
@@ -34,7 +34,7 @@ spec = Gem::Specification.new do |s|
s.add_development_dependency "rake", "~> 0.9"
s.add_development_dependency "rspec", "~> 2.11.0"
- s.add_development_dependency "mocha"
+ s.add_development_dependency "mocha", "~> 0.12.0"
s.add_development_dependency "yard"
s.post_install_message = <<EOS
View
@@ -6,7 +6,7 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Simone Carletti"]
- s.date = "2012-11-09"
+ s.date = "2012-11-11"
s.description = "Whois is an intelligent WHOIS client and parser written in pure Ruby. It can query registry data for IPv4, IPv6 and top level domains, parse and convert responses into easy-to-use Ruby objects."
s.email = ["weppos@weppos.net"]
s.executables = ["ruby-whois"]
@@ -25,18 +25,18 @@ Gem::Specification.new do |s|
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_development_dependency(%q<rake>, ["~> 0.9"])
s.add_development_dependency(%q<rspec>, ["~> 2.11.0"])
- s.add_development_dependency(%q<mocha>, [">= 0"])
+ s.add_development_dependency(%q<mocha>, ["~> 0.12.0"])
s.add_development_dependency(%q<yard>, [">= 0"])
else
s.add_dependency(%q<rake>, ["~> 0.9"])
s.add_dependency(%q<rspec>, ["~> 2.11.0"])
- s.add_dependency(%q<mocha>, [">= 0"])
+ s.add_dependency(%q<mocha>, ["~> 0.12.0"])
s.add_dependency(%q<yard>, [">= 0"])
end
else
s.add_dependency(%q<rake>, ["~> 0.9"])
s.add_dependency(%q<rspec>, ["~> 2.11.0"])
- s.add_dependency(%q<mocha>, [">= 0"])
+ s.add_dependency(%q<mocha>, ["~> 0.12.0"])
s.add_dependency(%q<yard>, [">= 0"])
end
end

0 comments on commit 1382187

Please sign in to comment.