Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Update development dependencies

  • Loading branch information...
commit 5013e0279f8b61161a7d97fbc83d6e2335f3b906 1 parent 01d722c
@weppos authored
Showing with 13 additions and 13 deletions.
  1. +3 −3 Rakefile
  2. +10 −10 whois.gemspec
View
6 Rakefile
@@ -32,9 +32,9 @@ spec = Gem::Specification.new do |s|
s.executables = %w( ruby-whois )
s.require_paths = %w( lib )
- s.add_development_dependency "rake", "~> 10.0.0"
- s.add_development_dependency "rspec", "~> 2.12.0"
- s.add_development_dependency "mocha", "~> 0.13.0"
+ s.add_development_dependency "rake"
+ s.add_development_dependency "rspec"
+ s.add_development_dependency "mocha"
s.add_development_dependency "yard"
s.post_install_message = <<EOS
View
20 whois.gemspec
@@ -6,7 +6,7 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Simone Carletti"]
- s.date = "2013-02-27"
+ s.date = "2013-03-20"
s.description = "Whois is an intelligent WHOIS client and parser written in pure Ruby. It can query registry data for IPv4, IPv6 and top level domains, parse and convert responses into easy-to-use Ruby objects."
s.email = ["weppos@weppos.net"]
s.executables = ["ruby-whois"]
@@ -23,20 +23,20 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_development_dependency(%q<rake>, ["~> 10.0.0"])
- s.add_development_dependency(%q<rspec>, ["~> 2.12.0"])
- s.add_development_dependency(%q<mocha>, ["~> 0.13.0"])
+ s.add_development_dependency(%q<rake>, [">= 0"])
+ s.add_development_dependency(%q<rspec>, [">= 0"])
+ s.add_development_dependency(%q<mocha>, [">= 0"])
s.add_development_dependency(%q<yard>, [">= 0"])
else
- s.add_dependency(%q<rake>, ["~> 10.0.0"])
- s.add_dependency(%q<rspec>, ["~> 2.12.0"])
- s.add_dependency(%q<mocha>, ["~> 0.13.0"])
+ s.add_dependency(%q<rake>, [">= 0"])
+ s.add_dependency(%q<rspec>, [">= 0"])
+ s.add_dependency(%q<mocha>, [">= 0"])
s.add_dependency(%q<yard>, [">= 0"])
end
else
- s.add_dependency(%q<rake>, ["~> 10.0.0"])
- s.add_dependency(%q<rspec>, ["~> 2.12.0"])
- s.add_dependency(%q<mocha>, ["~> 0.13.0"])
+ s.add_dependency(%q<rake>, [">= 0"])
+ s.add_dependency(%q<rspec>, [">= 0"])
+ s.add_dependency(%q<mocha>, [">= 0"])
s.add_dependency(%q<yard>, [">= 0"])
end
end
Please sign in to comment.
Something went wrong with that request. Please try again.