Permalink
Commits on Feb 9, 2017
  1. Merge pull request #104 from ashoda/bump_version

    ashoda committed Feb 9, 2017
    Bump version to 1.6.2
  2. Bump Version to 1.6.2

    ashoda committed Feb 8, 2017
  3. Modify where gem version is set and remove date from gemspec

    ashoda committed Feb 8, 2017
    Added a version file/constant to set gem version
    Remove gemspec `date` assingment. `date` no longer seems to be documented in
    http://guides.rubygems.org/specification-reference/ as a required or optional field.
Commits on Feb 8, 2017
  1. Merge pull request #102 from amcaplan/92_rails_5_params_deprecation_w…

    ashoda committed Feb 8, 2017
    …arning
    
    Fix Rails 5 params deprecation warning
  2. Match updates to JSON Schema validation error messages

    amcaplan committed Feb 7, 2017
    string and other JSON types will now be formatted as JSON types rather
    than Ruby types, see:
    ruby-json-schema/json-schema@853d0dc
  3. Switch params for HTTP requests based on Rails version

    amcaplan committed Jan 22, 2017
    Rails 5 deprecated sequential arguments in favor of keyword arguments
    (params:, headers:).  Since we want to support multiple versions of
    Rails without showing deprecation warnings (or totally failing in Rails
    5.1), use keyword arguments when working with newer versions of Rails.
    
    The strategy keeps things as close as possible to the Rails 5 version in
    Apivore::Validator to create minimal work later to remove the shim when
    Rails 5 becomes a gem dependency.
    
    Because Ruby 2.0 (which we still support) doesn't allow required keyword
    arguments, the shim uses defaults, but theoretically the defaulting
    should be handled in Apivore::Validator (as it currently does).
Commits on Feb 7, 2017
  1. Merge pull request #103 from ashoda/dependency_issues

    ashoda committed Feb 7, 2017
    Fix bundler dependency issues
Commits on Dec 13, 2016
  1. Merge pull request #99 from ashoda/rails_5_dependencies

    ashoda committed Dec 13, 2016
    Fix support for rails 5 without breaking previous ruby version support
Commits on Dec 12, 2016
  1. Bump Version to 1.6.1

    ashoda committed Dec 10, 2016
Commits on Dec 7, 2016
  1. Merge pull request #95 from nblumoe/patch-1

    ashoda committed Dec 7, 2016
    Add instructions for HTTP headers to README
Commits on Aug 11, 2016
Commits on Apr 28, 2016
  1. Merge pull request #80 from jatt/79_allow_rails_5_dependencies

    hornc committed Apr 28, 2016
    Change `actionpack` and `activesupport` dependency versions
Commits on Mar 28, 2016
  1. Merge pull request #83 from gwshaw/82_allow_use_of_full_url_for_consi…

    gwshaw committed Mar 28, 2016
    …stency_check
    
    82 Allow use for full URL for consistency check
Commits on Mar 26, 2016
Commits on Mar 3, 2016
  1. Change `actionpack` and `activesupport` dependency versions to allow …

    ekalinichev committed Mar 3, 2016
    …Apivore usage with Rails 5.
Commits on Feb 23, 2016
  1. Merge pull request #78 from hornc/master

    hornc committed Feb 23, 2016
    new version 1.5.0
  2. new version

    hornc committed Feb 23, 2016
  3. Merge pull request #77 from hornc/master

    hornc committed Feb 23, 2016
    update links to Open API Initiative
  4. Merge pull request #72 from mcinerney/rvm_tests

    hornc committed Feb 23, 2016
    [N/A] Add more ruby 2.2.x versions
  5. further OAI updates

    hornc committed Feb 23, 2016
  6. Merge pull request #76 from hornc/master

    hornc committed Feb 23, 2016
    update swagger 2.0 defs
  7. update swagger 2.0 defs

    hornc committed Feb 23, 2016
Commits on Jan 13, 2016
  1. Merge pull request #74 from hornc/adamcohen-master

    hornc committed Jan 13, 2016
    Print response body when test fails (v2)
  2. bump version

    hornc committed Jan 13, 2016
Commits on Jan 12, 2016
Commits on Jan 11, 2016
Commits on Dec 21, 2015
Commits on Dec 20, 2015
  1. Merge pull request #68 from hornc/master

    hornc committed Dec 20, 2015
    Better debugging and response access
Commits on Dec 9, 2015