Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Bump version

  • Loading branch information...
commit be0d91eec91c2a666998788bb710734376b6b7bb 1 parent 339e0ef
@galetahub galetahub authored
View
20 .gitignore
@@ -0,0 +1,20 @@
+pkg/
+Gemfile.lock
+.rspec
+spec/tmp
+spec/dummy/log/*.log
+spec/dummy/tmp/
+spec/dummy/config/*.yml
+spec/dummy/config/*.conf
+spec/dummy/config/logrotate-config
+spec/dummy/config/nginx-config
+spec/dummy/db/schema.rb
+spec/dummy/db/sphinx/
+spec/dummy/public/cache/
+spec/dummy/public/assets/
+spec/dummy/public/ckeditor_assets/
+spec/dummy/public/uploads/
+spec/dummy/vendor/bundle/
+spec/dummy/app/helpers/manage
+spec/dummy/config/database.yml
+spec/dummy/log/development.log
View
4 README.rdoc
@@ -24,6 +24,10 @@ backward compatibility with previous versions of Rails.
==Installation
+ gem "galetahub-simple_captcha", :require => "simple_captcha"
+
+or
+
gem 'simple_captcha', :git => 'git://github.com/galetahub/simple-captcha.git'
==Setup
View
19 Rakefile
@@ -20,22 +20,3 @@ Rake::RDocTask.new(:rdoc) do |rdoc|
rdoc.rdoc_files.include('README')
rdoc.rdoc_files.include('lib/**/*.rb')
end
-
-begin
- require 'jeweler'
- Jeweler::Tasks.new do |gemspec|
- gemspec.name = "galetahub-simple_captcha"
- gemspec.version = '0.1.1'
- gemspec.summary = "SimpleCaptcha is the simplest and a robust captcha plugin."
- gemspec.description = "SimpleCaptcha is available to be used with Rails 3 or above and also it provides the backward compatibility with previous versions of Rails."
- gemspec.email = "superp1987@gmail.com"
- gemspec.homepage = "http://github.com/galetahub/simple-captcha"
- gemspec.authors = ["Pavlo Galeta", "Igor Galeta"]
- gemspec.files = FileList["[A-Z]*", "{lib}/**/*", "{app}/**/*", "{config}/**/*", "{test}/**/*"]
- gemspec.rubyforge_project = "simple_captcha"
- end
-
- Jeweler::GemcutterTasks.new
-rescue LoadError
- puts "Jeweler not available. Install it with: gem install jeweler"
-end
View
52 galetahub-simple_captcha.gemspec
@@ -1,52 +0,0 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
-# -*- encoding: utf-8 -*-
-
-Gem::Specification.new do |s|
- s.name = %q{galetahub-simple_captcha}
- s.version = "0.1.1"
-
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Pavlo Galeta", "Igor Galeta"]
- s.date = %q{2011-08-22}
- s.description = %q{SimpleCaptcha is available to be used with Rails 3 or above and also it provides the backward compatibility with previous versions of Rails.}
- s.email = %q{superp1987@gmail.com}
- s.extra_rdoc_files = [
- "README.rdoc"
- ]
- s.files = [
- "README.rdoc",
- "Rakefile",
- "lib/generators/USAGE",
- "lib/generators/simple_captcha_generator.rb",
- "lib/generators/templates/migration.rb",
- "lib/generators/templates/partial.erb",
- "lib/simple_captcha.rb",
- "lib/simple_captcha/active_record.rb",
- "lib/simple_captcha/controller.rb",
- "lib/simple_captcha/form_builder.rb",
- "lib/simple_captcha/formtastic.rb",
- "lib/simple_captcha/image.rb",
- "lib/simple_captcha/railtie.rb",
- "lib/simple_captcha/simple_captcha_data.rb",
- "lib/simple_captcha/utils.rb",
- "lib/simple_captcha/view.rb",
- "test/simple_captcha_test.rb"
- ]
- s.homepage = %q{http://github.com/galetahub/simple-captcha}
- s.require_paths = ["lib"]
- s.rubyforge_project = %q{simple_captcha}
- s.rubygems_version = %q{1.6.2}
- s.summary = %q{SimpleCaptcha is the simplest and a robust captcha plugin.}
-
- if s.respond_to? :specification_version then
- s.specification_version = 3
-
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- else
- end
- else
- end
-end
-
View
2  lib/simple_captcha.rb
@@ -49,4 +49,4 @@ def self.setup
end
end
-require 'simple_captcha/railtie'
+require 'simple_captcha/engine' if defined?(Rails)
View
2  lib/simple_captcha/railtie.rb → lib/simple_captcha/engine.rb
@@ -3,7 +3,7 @@
require 'simple_captcha'
module SimpleCaptcha
- class Railtie < ::Rails::Engine
+ class Engine < ::Rails::Engine
config.before_initialize do
ActiveSupport.on_load :active_record do
ActiveRecord::Base.send(:include, SimpleCaptcha::ModelHelpers)
View
4 lib/simple_captcha/version.rb
@@ -0,0 +1,4 @@
+# encoding: utf-8
+module SimpleCaptcha
+ VERSION = "0.1.2".freeze
+end
View
65 simple_captcha.gemspec
@@ -1,57 +1,20 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
# -*- encoding: utf-8 -*-
+$:.push File.expand_path("../lib", __FILE__)
+require "simple_captcha/version"
Gem::Specification.new do |s|
- s.name = %q{simple_captcha}
- s.version = "0.1.1"
-
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.name = "galetahub-simple_captcha"
+ s.version = SimpleCaptcha::VERSION.dup
+ s.platform = Gem::Platform::RUBY
+ s.summary = "SimpleCaptcha is the simplest and a robust captcha plugin."
+ s.description = "SimpleCaptcha is available to be used with Rails 3 or above and also it provides the backward compatibility with previous versions of Rails."
s.authors = ["Pavlo Galeta", "Igor Galeta"]
- s.date = %q{2010-10-26}
- s.description = %q{SimpleCaptcha is available to be used with Rails 3 or above and also it provides the backward compatibility with previous versions of Rails.}
- s.email = %q{superp1987@gmail.com}
- s.extra_rdoc_files = [
- "README.rdoc"
- ]
- s.files = [
- "README.rdoc",
- "Rakefile",
- "lib/generators/USAGE",
- "lib/generators/simple_captcha_generator.rb",
- "lib/generators/templates/migration.rb",
- "lib/generators/templates/partial.erb",
- "lib/simple_captcha.rb",
- "lib/simple_captcha/active_record.rb",
- "lib/simple_captcha/controller.rb",
- "lib/simple_captcha/form_builder.rb",
- "lib/simple_captcha/formtastic.rb",
- "lib/simple_captcha/image.rb",
- "lib/simple_captcha/railtie.rb",
- "lib/simple_captcha/simple_captcha_data.rb",
- "lib/simple_captcha/utils.rb",
- "lib/simple_captcha/view.rb",
- "test/simple_captcha_test.rb"
- ]
- s.homepage = %q{http://github.com/galetahub/simple-captcha}
- s.rdoc_options = ["--charset=UTF-8"]
+ s.email = "galeta.igor@gmail.com"
+ s.rubyforge_project = "galetahub-simple_captcha"
+ s.homepage = "http://github.com/galetahub/simple-captcha"
+
+ s.files = Dir["{lib}/**/*"] + ["Rakefile", "README.rdoc"]
+ s.test_files = Dir["{test}/**/*"]
+ s.extra_rdoc_files = ["README.rdoc"]
s.require_paths = ["lib"]
- s.rubyforge_project = %q{simple_captcha}
- s.rubygems_version = %q{1.3.7}
- s.summary = %q{SimpleCaptcha is the simplest and a robust captcha plugin.}
- s.test_files = [
- "test/simple_captcha_test.rb"
- ]
-
- if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
- s.specification_version = 3
-
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- else
- end
- else
- end
end
-
Please sign in to comment.
Something went wrong with that request. Please try again.